No sound in the headphones at all?

I will appreciate very much your feedback!
So I’ve got UR22 MkII and installed Cubase LE AI Elements 12. Plugged in the guitar in line 2, opened a new track, the indicator shows that there’s a signal in, but no sound in the headphones.
What am I doing wrong, please?
Thank You!

Which “indicator”?

It’s hard to guess without knowing how your inputs/outputs are configured within Cubase.

Also, just to eliminate the obvious … your headphones are connected to the UR unit (not the computer’s headphone jack), correct?

Is monitoring enabled for the audio track?

And where is the mix knob set?

Also, have you set in- and outputs up in Cubase?

Thank You!
So I open for example a new recording track / a clean guitar recording.
In Studio Setup / Audio System / Yamaha Steinberg USB ASIO.
Audio Connections /
Stereo in 1 / UR22 MkII input 1
Stereo in 2 / UR22 MkII input 2
Mono in 1 / UR22 MkII input 1
Mono in 2 / UR22 MkII input 2
Stereo Out
Left/ UR22 MkII Output 1/L
Right / UR22 MkII Output 2/R

I open a new track, strum the guitar, and see an indication for a signal in Audio activity (Default Input Channel).
Then I enable the monitor but there’s this strange sharp sound, but no guitar.
What could be wrong?
Thanks beforehand!

The Hi-Z button is enabled, and the mix knob is in the middle.

Strange. What is your buffer set at? Maybe try to increase it bit and see if anything changes.

If you are monitoring through the DAW channel (not the direct input), you should probably have the knob set fully to “DAW”. I don’t think this has anything to do with your problem, though.

Does the interface work fine and output correctly for other sounds?

I’m afraid I’m out of ideas for now.

As Scab_Pickens say, if you want to monitor through DAW the mix should be set fully to DAW. Do you see output in the main out channels?

Main out channels?

I just needed to be braver in turning up the Input 2 Gain knob till the peak light flashes.
Thank You, everyone!