No sound on certain midi instruments

Hello everyone!

Currently I have an issue with getting sound output from certain vst instruments.

I am using midi tracks to trigger the instrument. I am using the control room.
The midi signal does reach the instrument, you can even see a key being pushed down, but sound is only heard when clicking directly on the keyboard of the instrument with the mouse.

This behaviour only happens to me with certain instruments like Korg Triton Extreme or AiR Xpand2!. Other Instruments work just find like they are supposed to.

I have tested a handful of methods like checking midi settings, general audio routing or monitoring buttons, but so far to no avail. What irritates me is the inconsistency with the problem.

As far as I remember Triton Extreme works fine in standalone using a keyboard and other Korg products work just fine so I guess its an issue within Cubase. I didn’t find any routing settings on the instrumnets themselves.
I hope anyone can help!

The screenshot suggests that you are clicking on the piano keyboard of the MIDI editor. Does this produce a sound?
Is it consistent? As in, you’ve never gotten those two VST instruments to react to recorded MIDI data in Cubase?
Have you tried opening Cubase in “Safe Mode” with preferences Disabled and starting with a new, blank project (not a template)?

What exactly is inconsistent?

Hey, thanks for your reply!

It does not create any sound. I am clicking the midi editor keyboard which successfully sends a signal to the instrument and triggers the GUI key on the keyboard of the triton. The mouse cursor is invisible in the screenshot.

This is a fairly new setup and this is my first time using those two instruments in Cubase12.
I was using Cubase 5 before and didnt have the instruments at that point.
In that sense, yes, its consistent cause I haven’t tried those instruments before inside of cubase (12).

Some instruments are working with a midi track input and some just don’t. Other Korg instruments for example just work fine, while the Triton doesn’t. So far I can’t make out the difference yet between those working and those that stay silent. I was thinking it might be their internal routing. As mentionend before, they even receive midi data, so technically they should create sound, but they only do when I click on the instrument’s keyboard directly. Xpand2! doesn’t have keyboard built in I think.

I have just opened a blank project but no change.

How do I start Cubase in safe mode and disable prefences?

This is exactly the symptom you’d expect if there was a mismatch between the MIDI Channel you are sending the VSTi and the MIDI Channel the VSTi is listening for. Try sticking a MIDI Monitor on a MIDI Insert & see if that gives you any useful clues.

Judging by the picture I’d say:

That MIDI channel should point (output) to the Korg TRITON VST.
That TRITON Extreme 01 Instrument track could produce sound, but only if Monitoring is enabled.

Don’t expect that MIDI channel to produce sound.

Okay, I think I have solved the issue.

What happened was that I again confused, or in this case didn’t pay attention to the track / rack function. Basically I was trying to send data from a midi track to a track instrument, which of course has it’s on inbuilt midi track and cant receive midi data from other sources.

“Back in the day” the difference in handling VSTi in Cubase5 was more pronounced. Hitting F11 would only open up the rack instruments while inserting a track instrument would require me to right click in the project window and add an instrument (track instrument) there.

I often find myself finding the solution after asking the question, which is a bit emberassing, but at least it’s working now!

So, thanks everybody for helping me out! @mlindeb @raino @Fantom
I think this should answer the remaining questions you guys had.

This is incorrect, a MIDI Track can send its output to a VSTi on an Instrument Track just fine. In fact if you add a New MIDI Track immediately below an existing Instrument Track by default the MIDI Track will be routed to the Instrument Track (or at least it did last I tried which has been awhile).

Yes, I have noticed that. Not sure if it has to be below the track, or how it works really. But it seems to be connecting automatically to that instrument.
I am just wondering what happens midi-channel wise. While technically the track instrument does seem to receive midi data, it doesn’t produce any sound. Whiche to me is strange cause the output of the VSTi shouldn’t be midi, right? Its not sending midi anywhere else…

You would have to either arm the track or enable Monitoring.

It increments the Track’s MIDI Channel Number. If you create an Instrument Track using Channel 1 and then add five MIDI Tracks under it, they will use Channels 2-6. Keep in mind that a Track’s Channel setting does not specify what Channel(s) the Track records (the Input Transformer controls that). The Track’s MIDI Channel Number setting controls the playback Channel regardless of the recorded Notes’ Channel Number. This setting is also used when you draw in Notes for their Channel Numbers.

hey guys, took a moment to get back to the thread. was very busy.

This part confuses me.

Let’s assume I have an Instrument (Triton Extreme) inserted, followed by a midi track. The instrument uses channel 1, the midi track uses channel 2. The output of the instrument is “Triton Extreme”, while the output of the midi channel is “Triton Extreme - Midi input”

Which tracks are you talking about in the quote?
And what is an input transformer?


If you use Instrument Tracks, you don’t need that second MIDI track. MIDI is recorded on the Instrument Track.

Every MIDI event (every Note On, Pitch Bend, etc.) has a MIDI channel. The MIDI channel setting that you find in the Inspector of MIDI and Instrument tracks forces the output of the MIDI events to a specific MIDI channel. Setting it to “Any” honors each individual event’s channel.

Yes, thank you. I am aware of that. I’m just creating this imaginary setup so we can talk about a specific example. I am trying to understand why sending midi data from a midi track to a midi track instrument doesn’t result in audible audio output, even though the instrument actually receives midi information.

You mentioned before that I would need to arm the track or enable monitoring, but I think that doesn’t apply in this scenario.

This is one of those things that sounds more complicated when describing it than it really is. Might be easier to experience it. Try this:

  1. Create an Instrument Track using Halion (or Kontakt)
  2. Load 2 different sounding instruments on Channels 1 & 2
  3. Create a MIDI Part on the Track and draw in a handful of notes using the Key Editor
  4. Select half the Notes and make sure they are set to Channel 1 on the Info Line
  5. Select the other half and set them to Channel 2 on the Info Line
  6. Now Loop the Part & play it back
  7. While it is playing switch the Tracks Channel setting between 1, 2 and Any

Okay, I will try this asap and will get back to you.