no sound out of my master keyboard on VSTi's

hello and thanks for the add

I’m a newcomer to Cubase with Cubase Elements 10.5.

I’m running it with a Nektar Panorama p4 and I am having issues with VSTi’s, no issues with audio.

Cubase runs on a Steinberg UR-RT2 interface with dspMixFx integration.

I don’t understand why I have no sounds from the p4 whereas it’s sounding with the virtual keyboards of the instruments.

hoping someone can help me,

have a great day,
peace

Hi and welcome,

Could you see incoming MIDI Activity on the Transport Panel? Is P4 enabled in the Studio > Studio Setup > MIDI Ports Setup? What MIDI Input do you have selected on the Instrument track?

before all,

thnks for your reply.

yes I see incoming midi, the p4 is enabled and I have tried all midi inputs one by one.

Hi,

Is there any patch loaded within the Instrument? Can you hear sound while playing on the Virtual Instruments’ keyboard?

yes, that’s what is weird, if I click on the virtual keyboards of Halion I can hear the sound but if I play on my p4 I get nothing

Hi,

Can you see the incoming MIDI activity in HALion?

Double-check Preferences > MIDI > MIDI Filter, please. Make sure, Note is not filtered out or specific MIDI Channel, please.

thank you for your reply again,

I am not at my studio today so I will tell you tomorrow
but I am pretty sure that my midi signal doesn’t reach my instrument however it reaches Cubase and that’s the core of my issue.

Is the track with the VSTi set to audition? (little speaker icon on the track header in project window, or beside the fader area in the mix console)

I have tried both, no sound from the p4 but on each virtual keyboards sounds

I always try to run Halion with one rhodes on channel 1 and my p4 is set on channel, by the way my p4 sees everything I can control and I can modify things such as release, cutoff etc and on audio channels I can control everything

I think the midi filter thing is something that deals with my issue, thank you,
I will tell you tomorrow,
meanwhile I have downloaded the manual (792pages​:thinking:) on my iPad 7 so will begin to learn at the source :grinning_face_with_smiling_eyes:

so I went to the midi preferences and here’s what is there
6A6B9045-8219-4396-B7B6-25A8401E2B64.jpeg

everything seems clean

incredible : I can record without hearing what I record,
but it plays

here’s how are the midi filters
6A6B9045-8219-4396-B7B6-25A8401E2B64.jpeg

Hi,

Aren’t the Channels enabled in the MIDI Filter, please? Lighter button = enabled filter.

they’re not filtered

thank you

something that I can do is recording but without sounds, and when I playback I can hear the sound playing.

weird isn’it?

I don’t know what I did but I have no more direct control on the track monitoring, I have to go in the ‘‘track edit’’ where are the sends, the channel strip and the outputs but it doesn’t matter as monitoring on or off I can’t hear nothing
:unamused: