No sound when adding new VST instruments in Playback menu


So I have got a new VST instrument (Joshua Bell Violin) that works with Kontakt that I am trying to get to work properly:

So, I already had an existing project with 2 existing violins that were automatically assigned to and played by the “Halion Sonic SE - Violin”, and I wanted to change the settings so that these two violins were played by my new VST “Joshua Bell Violin” instead of the Halion.

So, I went to the playback menu and clicked on “Add” under the instrument panel (to the right) to add a new VST instrument and chose Kontakt - then I went to the instrument section (on the left side of the playback menu) and changed the VST settings for both of my violins to my newly created VST (which became “04 - kontakt”).
This worked, however - I realized that I didn’t want the two violins to always have the same settings (since I wanted them to have different timbre and character), so I figured that I could solve this by adding another slot of the same VST and assign the first VST to violin1 and the second VST to violin2 (so that violin1 uses “04 - kontakt” and violin2 uses “05 - kontakt”), however this is where the problem started:
Violin1 works perfectly, I can hear it in the playback and I can hear it when playing on my MIDI keyboard, but Violin2 (that is played by “05 - kontakt”) has no sound at all, neither in playback or from the MIDI keyboard, however if I assign violin2 to “04 - kontakt” (the same VST as violin1) then I suddenly get a sound from violin2.
So it seems that the newly added VST “05 - kontakt” is not giving any sound at all for some reason, and I’m wondering why and how I could solve this?

Sorry for this very long, and detailed explanation, I just figured that it was a very specific problem so I didn’t want to leave any information out.

Thanks in advance.

Check the midi channel of the violin2 is set to 1 (Halion will have set it to 2)

If you are using two instances of Kontakt instead of putting both into a single one, then both channels will be 1 in Kontakt and channels in the VST must always match the allocation in Dorico. In other words, exactly what @Janus said.