No sound when inputting notes with MIDI keyboard.


New user to Dorico here, making the switch from Sibelius.

For some reason during inputting notes, I do not hear any note feedback when inputting from a MIDI keyboard. The notes input fine, but I do not hear them until I click on them with my mouse, or go through playback.

However, if I input notes using my computer keyboard or mouse, I do hear note feedback when inputting those notes. It’s only when I use my MIDI keyboard to input notes when I do not hear any audio. Let me know if there is a quick fix to this, thank you!

Also, separate issue if anyone wants to weigh in on this. Note input can be extremely laggy, as in it takes about a second per note to process and show up in the score. I only have one MIDI device plugged in, and the MIDI light indicator isn’t going crazy as if it were getting too many messages. I’ll input a 16th note phrase over one measure with my MIDI keyboard, and it’ll take 10 seconds or so to catch up processing one note at a time. This laggy behavior happens with all sorts of things as well, and I’m on a very powerful computer. (Windows 10, i9-9820x, 64gig RAM, etc)

Thanks for the help!

Is it possible that you have ‘Enable MIDI thru’ switched off, on the Play page of Preferences?

As for the very slow performance during note input, is your project exceptionally large? Are you inputting with Edit > Condensing switched on? Would you be comfortable sharing your project here, zipping it up and attaching it to a reply, so we can take a look?

HI Daniel,

Thank you for such the quick reply. The project is a standard orchestral layout for the most part, and it’s only about 40 bars so far. I am not inputting with condensing switched on. The midi thru was turned off, thanks for that! Attached is the requested file.
Laggy Note (1.16 MB)

Note input in your project is about as quick as I would expect, which is to say pretty snappy. Would you please perform some note input in your project, then do Help > Create Diagnostic Report and attach the resulting zip file (saved to your desktop) to a reply here?

Sorry for the delay. Below is the diagnostic file after I inputted some notes. The file is too big to attach it here. Also, I included a video showing how long it takes for notes to input from a MIDI keyboard.

Update: The issue isn’t just related to the MIDI controller. Using the standard computer keyboard for note input gives laggy input as well (about 1 second per note entered).

The issue extends to other areas of the program as well, such as undoing, inserting dynamics and articulations, moving notes, and anything that changes the score in some fashion. Everything has about a second delay before it responds to any command.

I can see from the log that it’s spending most of the time having to re-space the project. Is this is a very big file, do you have condensing turned on or a very large page size?

Also I notice you have a crash log in there due to a known problem with the Suspend Audio Engine in Background preference, so I would advise turning that off.

The issue persists regardless condensing is turned on or off. The page size is whatever the default is.

I went ahead and turned off the “Suspend Audio Engine in Background” preference just to be safe. Problem still persists. Appreciate the help!

Update: Did a clean reinstall, and now with condensing turned off there isn’t nearly as much lag as before. I’m not sure why condensing would cause those issues for parts of the score that are not condensed, but at least there is a workaround for now. I can confirm that condensing was indeed the issue, but that only helped once I did the reinstall.

Thank you for the help!

If condensing is turned on, then there’s a lot more calculation that has to happen every time you make an edit to the score, even if you are editing a different instrument. This is because there is a complex inter-dependence between all instrument staves. If you add an extra note to any instrument, Dorico has to re-space the bars, and that could cause an over-full bar to be pushed on to the next system, but that could cause an orphan, so it’ll take other bars with it. That will affect the bars on previous systems, and if the range of bars on each system changes, then the condensing has to re-evaluate whether the current condensation is still valid, and so on. The general advice is to turn condensing off during the writing stage of the project, and turn it on when you’re ready to produce the printed score.