No sound with Realtek ASIO driver / Cubase Pro 9

Hi,

Sometimes I need to use the inbuilt sound card on my laptop while running Cubase Pro 9, and so far the Realtek ASIO driver has worked perfectly. Until suddenly today…Cubase recognizes the driver as usual, but there’s no sound anymore, and latency values on Device Setup show 0 (unknown). I’ve tried tweaking this for hours now but no result. Would anyone have any idea what could be the problem?

Realtek driver is still working perfectly with other applications, and all the settings with the driver etc. are the same as they were when it was still working with Cubase a couple of days ago.

Curiously, the Vista driver for my external sound card (my Edirol UA-5 is too old but it’s been working perfectly in Windows 10 and in Cubase using the Vista driver) started having problems after the recent Creators Update for Windows, with the sound disappearing for good every 5 minutes, while the Realtek driver worked perfectly…until a couple of days, when the Vista driver suddenly started working fine again, without me having to do anything. Now I wonder if this has something to do with Realtek not working anymore (I can’t see any logic in this, but then again computer behavior tends toward illogical, especially with Windows).

Thanks for any advice!

Regards.

I just discovered my new computer has this built in realtek ASIO driver and I get the same thing. Latency reported as zero and no sound. I don’t really have any complaints with the Steinberg Generic Low Latency ASIO driver when I am away from home without the audio interface but it certainly made me curious. I would really be interested to know if anyone has had any luck using it.

do me a favor. Make sure 64 bit processing is turned off, restart Cubase and try again. Someone else is having problems if they have 64bit enabled. It would be interesting to see if that is this problem.

Same results here.
I can confirm this result on MSI GS60 Ghost Pro 4K 6QE laptop
The Realtek ASIO driver does not produce sound.
Shows latency as “???”

However, I think it may be defaulting to use only the optical spdif side of the dual use headphone jack as the output and gives no option to change it.
It does not work in either 32bit processing or 64bit processing.

Generic low-latency ASIO works perfectly as expected in both 32 and 64 on speakers and headphones
Asio4all also works perfectly as expected in both 32 and 64 on speakers and headphones

Trying the standalone izotope ozone 8 with the Realtek ASIO to verify operation,
it works on both laptop speakers and headphones.

Tried the Realtek ASIO with a toslink to mini digital optical spdif to external DAC
and it does not produce sound in either 32 or 64.

Generic LL and Asio4all work in both 32 and 64 with this setup.

I don’t know exactly where to turn off 64 bit processing. Is that a Windows setting or a Cubase setting?

But, I tried with Absynth Standalone after reading the above post and it worked BUT I had to select a sample rate (defaulted to zero). Then, I closed Absynth and opened Cubase. Now it reports the same latency as Absynth did but still no sound (it did show the audio outputs connected and active).

A Cubase setting.
Found in Studio -> Setup
In Cubase Pro 9.5

That explains it… I only have Cubase 9. All 32 bit processing. Makes sense now.

Maybe it’s an SPDIF thing. I’m on OSX, Saffire Pro 40, My main keyboard: K2500XS connected via SPDIF-OPT. Abelton Live 9 Suite records audio just fine. Cubase 9.0 and 9.5? No joy. Only analog ins work in Cubase. As someone who picked up Cubase Pro 9.0 three weeks ago and just upgraded to 9.5 (the grace period is nice, thanks Steinberg!) it’s super frustrating…especially considering the exact same hardware and setup works in the other DAW.

Having the same issue, and Google brought me to this thread. Should I just stick with using the Steinberg Generic Low Latency ASIO driver, or would using something like ASIO4ALL be a better choice? Thanks for any help!

ASIO4all should be better than the generic low latency driver.

thnaks so so much everyone!