No valid Lic found...Code used already

I just bought Cubase Elements 7. Using Windows 7 64-bit. First time installing it, I type the license number and seems to activate. But when I try to start the program, this pops up:

Then I try to type the license again…

Tech support appreciated :slight_smile:


Can you see the license in the eLicenser Control Center application? Make sure, you have the latest version, which you can download here.

I wasn’t aware of the eLicenser software. I started the eLicenser and immediately a window pops up saying the database was outdated. Ran the update. Works now!



just gone through the installation process in my ur28m and got the same problem as above. I have tried what has been suggested but still not working I have ran the maintenance and revovery options.

please help

Hi and welcome,

What OS do you have? Can you see the Soft-eLicenser Number in the eLicenser application? Do you have the latest update of eLicenser Control Center?

With UR28M, there is Cubase AI, or any different one?

Thanks for the reply, I have managed to fix the problem by uninstaling everything and trying again. have no idea what went wrong but on the second attempt i did not click on the updates option and my licenses worked fine.

Thank again for the reply I am sure I will have plenty more questions as i delve deeper into the world of computer recording.

goodbye tascam 2488 neo and hello cubase !!!