No view on my host (Reaper)


I dont know why my view is not working, could be related with some pre-setting on my XCode, but I create the project with my VST3_Project_Generator, so everything should be presetted, I share some screenshot of the .uidesc file and the location. My idea is to create two knobs to control the volume of each sine-wave.

.uidesc file and location:

I also shate the st_params.h file where I think that I should defined the tags for controller.cpp

When I compiled the project, the plug-In makes sound so the DSP is correct, but I always see a black page, also I tried to use the UI editor, then save and replace the .uidesc file in my project but still not working. I will hope that the question is clear, any help will be appreciated.


You must be using an “old” version of VST because the format for uidesc is now json not xml like in your screenshot (and this has been the case for a while).

But besides this, have you tried with the VST3PluginTestHost that comes with the SDK?