Not getting sound from Roland keyboard as midi target

I posted this on the “older versions” board since I have Cubase 6, but have gotten no responses, and I don’t think it’s a version-specific problem, so I’m posting here in the hopes of getting some guidance.

Chances are this is a freshman mistake - I will forever be a newbie as I get a chance to play with this stuff about once a year on average…

Cubase 6
Roland RD700SX
Steinberg UR22
Windows 10 on Dell XPS 8300

I have recorded a midi track on Cubase 6 using a Roland RD700SX keyboard. I would like to output that midi track to the Roland and record an audio track with the Roland as the audio input.

The Roland is connected to my pc via a MIDI-USB cable (connected to midi in/out on Roland and USB port on pc):

With this setup, I recorded the MIDI track, so I know the cable and port works. With the track set to the same MIDI port for output, on playback I don’t hear anything although I see the MIDI activity on the Cubase bar as the notes play. This is true whether I am listening to the Roland directly through headphones, or if I have headphones on the UR22, to which the Roland’s line output is connected:

If I play the keyboard manually, I can hear that output through the UR22, so I know that connection is fine.

On the keyboard side, I have the following settings:

…although I’ve tried toggling MIDI through, local on/off and other things to no avail.

On Cubase, here is a screenshot of the project:

The Piano track is there because that is plan B if I can’t get this to work. On the MIDI track, I know the selected MIDI port is the right one because I can record MIDI from the Roland on it. Also, it shows as active in the MIDI Port Setup:

One thing I don’t understand is what role in this the MIDI Device Manager should play, if any. Originally there was nothing there, then I tried “install device”, which gives a list of devices that doesn’t include Roland RD700SX, so I selected GM Device, and assigned it to the MIDI port in question. Do I need to do something else to this to make it work?

Also, do I need to do something with the bank selector and program selector (both set to OFF as seen in the project image)?

To illustrate the level of flustration I’m at with this, I saw a related post where someone advised the OP to check for “midi trough” and I spent several frustrated minutes searching the manual and other posts for this new setting called “trough” before realizing he had typoed “through”. So, be gentle!

Thanks in advance for any guidance or ideas. If this was more intuitive and less complicated, I’d probably use it a lot more often - my acoustic piano just works!


I would simply suggest using the UR22 midi ports rather than that adapter thingy.

2 things
1: where is your audio track for the audio out of the synth? (chan 1 of UR in / default out)
2: why do you have +48V phantom power enabled for your synth on the UR?

remember … midi contains no sound only data

best of luck

DLearyUS makes an actually useful suggestion. I clearly got lost among the jpgs and came out the other side with only most of my brain matter intact. :confused: :unamused: :blush:

On the MIDI track, I know the selected MIDI port is the right one because I can record MIDI from the Roland on it. Also, it shows as active in the MIDI Port Setup:

You know the input port is the right one but there is zero evidence the output port is the right one.
It only shows as active because you have selected it in the project.

Try the other output port that’s listed.

Thanks for all the input. The problem has been solved by connecting the MIDI through the UR22 instead of a USB interface to the pc. Works like a champ.

I tried all of the other suggestions first but nothing worked (turning off phantom power, trying all other ports, etc.).