Not hearing my keyboard in Cubase AI 8

I’m still in the early setup stages…but I’ve hit a snag. I’m trying to hear what I play on my keyboard through my studio monitors (using Cubase). I have a Yamaha S90xs keyboard, Yamaha HS8 monitors and I’m using Cubase AI 8.

Right now my keyboard is connected to the computer with USB, which it recognizes, and my monitors are connected to the computer with a 3.5mm to dual 1/4" wire, which it recognizes. At first I tried using a Steinberg UR-mkII as a go between but that didn’t work either so I decided to try this setup because it seems simpler.

After reading the Operation Manual (which doesn’t go into much detail), it seems like the problem is most likely the settings within Cubase.

In VST Connections, I have the Output set to Generic Low Latency ASIO(the only option) with the device being “Speakers/Headphones”.
The Input is also set to Generic Low Latency ASIO(also the only option) with the device being “Stereo Mix”.
Shouldn’t the input be the keyboard??

Also, when I create an instrument track using my keyboard as the input, the only options for output in the track inspector are “No VST Instrument”, “S90 XS VST”, and “HALion Sonic SE”. Shouldn’t there be an option for Speakers?
When I look in the Channel Settings there is a “Stereo Out” option but that doesn’t work either…

I’m pretty new at this so there’s a good possibility I’m doing it utterly wrong. Many thanks for any help you may have.

There are a few ways to get going with this. Here is one way…

Install the ASIO driver for the UR and choose it in the Cubase Devices>Device Setup>VST Audio System>ASIO Driver drop down menu. Then connect your HS8 monitors to the UR. Then go into the the Cubase Devices>VST Connection menu and setup the I/O buses in the appropriate input and output tabs.

  • Connect your keyboard to the computer before starting Cubase (Cubase won’t recognize it if it is connected after CB is started). Make sure your computer recognizes the keyboard.
  • Turn on the keyboard.
  • Set the midi function to “Local Off”. Check the keyboard manual to find out how to set it to “Local Off”
  • Start Cubase
  • Open an existing or new project.
  • On an instrument track choose “All midi inputs” in the input routing field (this setting is in the track inspector section.
  • Just below that in the track inspector section choose a VST instrument like Halion Sonic SE and choose a sound from what is available.
  • Enable the track “Monitor” (button looks like a speaker) function and now you should be able to hear your keyboard thru the monitors or headphones connected to the UR.
  • Record something. To hear what you recorded you must disable the track “Monitor” function.

Good luck and have fun :wink:

Regards :sunglasses:

Thanks for the response, Prock.
I was able to hear my keyboard by following your instructions…HOWEVER…

The sounds I was hearing were from HALion Sonic…and what I hope to do is hear the sounds of the keyboard ITSELF.

For example I have a custom Voice on my keyboard that I would like to hear played through my monitors but if I plug my keyboard directly into my monitors then I can’t work with that voice in Cubase…recording/editing etc.

Is there a way to maybe import a voice or voice library into Cubase from my keyboard?

Thanks again.

I can’t get detailed right now so take a look in the CB manual for setting up an external instrument. Or maybe someone else will chime in to assist further.

Regards. :sunglasses:

Check out these vids. Hopefully you can follow them. The one thing that I am not sure of is if your Cubase AI 8 version has the ability for these features.

https://www.youtube.com/watch?v=UW9i_-yhypw

https://www.youtube.com/watch?v=_zWK5BlpkwQ

Regards :sunglasses:

Prock,
Thanks for the help. Those videos did shine light on my problem, which might be my version of Cubase…
I will most likely upgrade to Cubase Pro at some point in the future…

In the meantime I found a psuedo-solution for my issue…but thanks again!

-Zoberflote

1 Like

What pseudo-solution did you find?