Not Seeing Midi while recording in Edit window

Hello friends. I have a weird problem that I’ve never experienced before. When I record midi while the piano-roll editor is open, the midi doesn’t show up until after i’ve pressed stop and the recording is made. This happens on both midi tracks and vsti tracks. If I make the recording while in the project window, I can see the parts update in realtime, but while in the editor the midi doesn’t show up until afterwards.
In my previous version of cubase this functionality was never an issue.

I’ve tried both “merge” and “new parts” selected on the transport with no luck.


Update: I’ve just tried Cubase 8.5.20 and this issue doesn’t come up. I’m able to record and see my midi recording in real time in the edit window, so the issue is related to Cubase 9.0.30.


Thanks
F

Windows 10, Cubase 9.0.30

Hi,

There are two ways of recording. You can record to the editor, then you can see the date. Or you can record in the Project, then a new MIDI event is created, so you cannot see the new data in the currently opened editor.

To record to the editor enable the record in the editor. Then you must not click to the Project window and keep the focus in the editor and start the record (for example via Key Command or Remote Device).

That works - thank-you; replies to a question I posed in another topic.

Thanks so much. That record enable in the editor is new to me. Thanks so much. Also, is there a way to have it default to recording in the editor?

All the best

No, you cannot set the Record to Editor add default, because Cubase is recording to the parts not to the tracks.

I’m not sure I follow.

Simple answer: No, there is not a way to have it default to recording in the editor.