Note entry forced to end of previous bar?

I’m enjoying looking at the new software: most of my other gotchas have already been captured elsewhere on the forum (select-all doesn’t work, lack of sensible selection tools, bad behaviour of VST backend on crashes, etc).

However, I’m trying to prepare a keyboard part for a vocal piece and I have a oddity that seems to be occurring on a particular part of my score that I can’t explain. If I try and insert any notes within the first 3 quavers of one of my bars it forces me to start the note at the final semiquaver of the previous bar. It only does it with the one bar, but it’s the same effect whichever staff I try to insert on.

I’ve attached a screenshot to demonstrate, although unfortunately since it didn’t capture the mouse cursor it’s not so useful. You can see the effect at the start of bar 5 on the ‘Piano 2’ treble staff. The mouse cursor was under the highlighted note (the G natural semibreve) at the C position, and I pressed shift-N wanting to insert a note at that point, but the ghost note is actually at the end of the previous bar (grey semibreve in the C position on the treble staff). This happens for any position until the 4th quaver position, at which point the insert point is where I’d expect it (second screenshot).

I’m not sure what I’ve done to get the score in this state: I did try and have a look around the properties windows but to no avail. There had been a double bar line and a new cut-time time signature here before (this file was imported from a MusicXML file generated by Sibelius) but deleting that didn’t help. Can anyone explain this effect?

I’m also mightily confused by the way the software is assigning voices. Judging by the colour-by-voice options I seem to have about 10 different voices at various points, particularly in the music I’ve been inputting myself in Dorico (everything in the ‘Piano 2’ staff; Piano 1 and Voice were imported). It seems the shift-V option to insert mode is adding a new voice every time, rather than using the minimum number of different voices in a bar. Is this intentional – is there some subtlety in the way multiple-voice note entry is supposed to work that I’ve missed? Hopefully once the facility to see and alter voices from the properties bar is available this will become slightly less opaque.

(oh, and at one point the voice colour option was showing me one of my voices in a bright yellow that was almost impossible to see against the white score; can the colours be fixed to make sure they will all show up?)
insert-mode-working-example.png
insert-mode-odd-example.png

Don’t use Shift+V every time you need to write in a different voice: use V on its own to cycle between the voices you’ve used somewhere on that staff. It’s very rare to need more than two up- and down-stem voices on the same staff, so normally you wouldn’t have enough voices to get to yellow voices that are hard to see. (The voice colours are decided algorithmically by traversing the colour wheel, so in the end if you have enough voices you’ll get all sorts of unpleasant colours, but the first four to six of them are basically fine and provide sufficient contrast against the paper, and that’s normally more than enough.)

Regarding your odd bar length problem, I guess that deleting the barlines there has left the bar with a funny irregular length. You might try creating another 4/4 time signature at the start of the bar that behaves weirdly, which should prompt it to put the following barlines in the right place, and hopefully that will sort it out. If not, please zip up the project and attach it here and one of us will take a look.

Aha, thank you for sorting out my confusion between shift-V and V. I shall now eagerly wait for the update that allows me to edit voices for existing notes. :slight_smile: Indeed I don’t think I’ve ever needed more than 4 voices when I was doing things properly.

I did try adding a new time signature to the odd bar but it didn’t help. Deleting the old (double) bar line didn’t actually cause the problem; it was something I did to try and correct it. As far as I can see it is being processed as a standard-length bar – I can edit the notes that are already in it perfectly well out of insert mode (e.g. changing their lengths or pitches), it’s just when I try and go into insert mode it forces me to the end of the previous bar until almost halfway through.

I can see the 4 crotchet ruler above the bar I’m in, laid out correctly: when the shadow note is pushed to the previous bar I also see a second ruler above that bar. Anyway, I’ve attached the zipped .dorico file so if you could take a look and tell me what I’ve done to it I’d be very grateful!

(and I just noticed the timestamp on your message: thank you very much, 11 o’clock in the evening answering support requests is definitely above and beyond the call of duty…)
IRemember.zip (402 KB)