Note Input VERY SLOW

Tried getting an answer on Facebook to no avail, so I thought I’d try here.

Something weird is happening all of the sudden. Note input takes FOREVER now.
I hit a note on my keyboard, and it take about 6-10 seconds for it to enter on the staff.

Any ideas as to what might by causing this? I reset the playback template to a default, and it’s still doing it
Also, my samples (especially the piano) seem to have slight distortion, and are breaking up slightly.

I wonder if my NI Komplete Kontrol 88 may have something to do with it?
When I turn it off and enter notes on the computer keyboard, the lag goes away.

It’s just weird, because this has never happened before today. I’ve work on full orchestra scores with no issues, now it’s happening on a 2 staff sketch

Yep, it’s almost certainly your MIDI controller. Have you checked to make sure the drivers are current? I’d wager it’s incorrectly sending continuous data.

Thanks Dan! I’ll look into this tomorrow

This can be a mod wheel that has dust in it, or whatever thing pressing a button… Is there a reset button in the NI Komplete Kontrol 88 that could solve it?

Hello,

The slowness occurs if you input new notes, for example, on page 3 and your document has already 20 pages.
The reason is that Dorico recalculates the layout immediately after you input a new note or erase a note.

I would like to do as follows:

  1. Creating a new flow at the end of the document
  2. Working there
  3. Copying all notes, tempo markings, time signatures, key signatures etc.
  4. Inserting them into the proper place.

I don’t agree with prko’s advice, and I would advise against following it.

I think the most likely cause could be a MIDI feedback loop, where you have the same device active as both a MIDI input device and a MIDI output device. In the ‘MIDI Devices’ dialog accessed via the Preferences dialog, make sure you don’t have e.g. ‘IAC Bus’ chosen as an input device. In fact, I’d recommend explicitly deactivating every device apart from the one you’re actually using for input.

Yes, it’s definitely a keyboard controller issue. I’ll look at my preferences.

Thanks as always, Daniel!

Ehm… currently, there are more than 100 pages in one of my Dorico project file.
There is a time difference between inputting notes in the first flow and inputting notes in the last flow.
For me, it does not take 6-10 seconds when inputting one note into the first flow.
However, inputting ten notes in the first flow takes several seconds longer than inputting ten notes in the last flow.