Note labels for the black keys

Total noob here. In another thread I’m trying to find out how to turn off the note labels in the Key Editor, but in the meantime I have another question . . .

I notice in my Halion Sonic Se piano composition it always labels the black keys as sharps, i.e., the black key above A is A-sharp, not B-flat, which is annoying because I’m writing something in F-minor.

In another thread someone here said you could fix that by putting in a chord track in a key with flats. So I added a chord track in F-minor, where B, E, A and D are flatted. But that made no difference. So what is the trick here - how do I tell Cubase what key I’m in so it labels the notes properly?

Thanks in advance.

Hi,

HALion Sonic SE is a plug-in, which doesn’t respect Cubase settings.

https://steinberg.help/cubase_pro/v11/en/cubase_nuendo/topics/preferences/preferences_event_display_chords_r.html?hl=chord%2Ctrack%2Cenharmonic

Of interest: Enharmonics from Chord Track

Uses the chord events on the chord track to determine if enharmonically equivalent notes in the Key Editor and in the List Editor are displayed as sharp or flat.

What this means is that if you create a chord track and put an “F minor” chord/event there, once you open the key editor for the part “covered” by this chord, you will get the notes spelt accordingly (in F minor’s case, 4 flats)

1 Like

HALion Sonic SE is a plug-in, which doesn’t respect Cubase settings.
The question is about the Key Editor, not Halion Se. The Key Editor is is supposed to respect Cubase settings.

As I said in the OP, I did that and it didn’t seem to work.

Maybe I did it wrong because I’m a noob. Where is the correct way to force the Key Editor to display the keys in the desired chord documented?

But that raises another question - If I write a piece with, say, 50 measures in it, does that mean I have to create 50 measures worth of chord tracks just to get the Key Editor to display the notes in my preferred key?

Hi,

Is the Enharmonics form Chord Track option in the Preferences > Event Display > Chords & Pitches page enabled, please?

1 Like

Ah-Ha! That fixed it. Thanks!

You wrote: once you open the key editor for the part “covered” by this chord, you will get the notes spelt accordingly (in F minor’s case, 4 flats)

… could you clarify that part? I only have the chord set for the first measure. But just now I tried adding notes in measures 2 and 3 and they also display correctly, which is good. But how long is the part that’s “covered” by this setting? Will it last until I put in a new chord in a different key, say if I want to change keys in mid-composition?

I see @Martin.Jirsak is always standing by!

Here:

First measure is F minor. All B, E, A, Ds are flats.
Second measure is E major. All F, C, G, Ds are sharps. If I continue writing from measure 2 onwards, everything after the E major chord will be handled as E major.

So yes, until you enter a new chord, spelling will respect the current chord. (You can just enter chords when a modulation happens e.g., there’s no need to write the whole harmony. For example you might have a whole section in C major, but with several chords, D minor, F major, G major etc. But then it might modulate to a far Ab major. It would then suffice to enter a Ab Chord at the point where the piece modulates, and all would hopefully be well. If a certain need arises, for example if a Dmb5 chord is spelt as D F G# C in that C major section, you can always manually add it in the chord track. This is very good for the score editor too, as you don’t need to go manually respell accidentals on many parts.)

2 Likes