Note Length + Legato Question (Expression Maps/Dorico 3.5)

Hi all! With all the wonderful new features now available in Dorico 3.5, especially in regards to Expression Maps, I have been working to set up a custom playback template for my various sample libraries/virtual instruments, and have run across a curious situation: while using the new note length feature to allow for “unmarked” shorts to play back using staccato samples, it seems as though notes of short duration under a slur/legato marking are being played back using short samples as well, and I cannot determine the best way to override this behavior. Ideally, all notes under a legato marking should only play using long/legato samples, and unfortunately setting legato as a base technique causes issues with situations like tremolo + legato. Is there a configuration option I’m missing, or potentially a better way to go about setting up my expression map for this instrument? I would really like to take advantage of the note length feature as it definitely improves playback and reduces the need to add extra articulations overall.

Welcome to the forum, kspierson. Perhaps you could try adding a playback option override in your expression map to prevent staccato notes from also having their duration reduced?

Hi Daniel,

I’m not sure how that would help exactly; the issue I’m seeing is that short notes under legato/slur lines are being played using a short patch when I would like the fact that it is under legato/slur to override the expression map note length settings. Right now the note length expression map overrides are on the “Natural” technique, and applying it to “Non-Legato” doesn’t seem to work as expected; in addition, it doesn’t look like add-on techniques understand the concept of note length. (Ideally, I would add legato as an add-on technique with CC64, but seems to be a separate issue with the off events for legato being triggered at the appropriate time, which causes hanging notes when bank changing). Again, I’m not sure if I’m missing something or if there is a better alternative way of handling this other than creating a base legato expression map technique; I’ve looked at the exclusion groups but since this is specific to the note length condition I don’t see a way to override using those.

Thanks for your help,


The issue seems to be:

First note of a legato phrase (say with slur marks over it) should NOT be played legato. Subsequent notes under the slur SHOULD be legato (including the last note of the slurred phrase).

Oddly, Dorico is assigning the legato event at the first tick of the first note in the slur, and letting it go when it plays the last note under a slur. Because of this the first note of the phrase is played legato (and it really shouldn’t be), and the last note living under the slur doesn’t get the legato attack as expected.

Example: 4 quarter notes living under a slur.
Dorico plays them
da da da ta

When they should be
ta da da da

My personal fix for instruments that use the legato pedaling method are:

  1. Don’t use legato in expression maps at all. Remove them from the expression maps, period. Instead, set an extended length for legato in Dorico’s default play back parameters. For most things this works out fine, as setting a note length for legato notes longer than 100 creates a little overlap or crossfading effect for legato/slurred passages using the nat/ord sound (the traditional general MIDI method of doing legato).

In cases where I really want a substitute legato sound, I’ll force them in manually using some method other than Dorico’s built in legato technique.

  1. When using HALion instruments, I have HALion 6, so I’ve built myself lua scripts that can delay the pedal CC (or key-switch, or whatever triggers the articulation change) a few milliseconds. This fixes it…both for the first note of the phrase, and the last.

  2. When using something besides HALion…such as Garritan Personal Orchestra, I’ll host it in an instance of bidule. Bidule allows me to delay the CC (and/or keyswitch) involved in selecting the legato articulation a few milliseconds. It also delays the release event sent by the expression map, so the last note under the slur is also played legato.

  3. Another possibility is to compose as you normally would, disable your visible slurs, then add new slurs that begin and end a note later than they should, and hide them. Royal pain, but it would work.

In short…
If you have a way to delay Dorico’s native legato event a bit, your legato articulations triggered via the “legato” technique in expression maps will work well. If not, then you’ll get some odd results when trying to use the built in legato techniques via expression map. At least that has been my experience.

Quite a few of my instruments use the legato pedaling method (CC68, or CC64).

So for me at least…I either don’t use Dorcio’s native legato technique at all in expression maps…or…use scripts, or bidule to intercept the relevant pedal event(s) (or key-switches) and delay them a bit.

For nearly all instruments, staccatos under a slur is equivalent to tenutos. Exceptions might be double and triple articulations on winds and “sons filés” for voices (and in some of the late Beethoven piano sonatas).
For your expression maps, you should set a command “legato+stacc = tenuto”. At least it’s the way I found to make it work. The tedious part, depending on your library, is that you might have to setup more subcommands for fp, sfz…


I actually am not having issues with the start of the legato phrase being played right, it’s that any note inside of the slur marking that Dorico has designated as short (based on tempo/note value) ends up triggering a short patch instead of continuing on using the legato/sustain patch. For context, I’m using LASS set up in multi-bank instruments in lieu of keyswitching; this library has legato sustains, tremolos, and trills, but no legato short patches (or shorts other than staccato/spiccato). I don’t necessarily need an add-on technique specific to legato in my expression maps, as overlapping the midi notes works for the library; what I am looking for is a way to ensure that, should a note be designated as short but under a slur mark, the note length rule for “Natural” does not get triggered. Is there something I’m missing? Or is there an alternative way to configure this expression map to work as I need it to?




Interesting! I’m actually not marking any of these notes at staccato under a slur–it’s simply a line with note values ranging from a sixteenth note to a half note. What is happening on playback is that any note that is “short” (in this case the 16th note) would get played with the staccato patch, even with the legato marking, because of the note length condition on the “Natural” technique. If I had no slur, it would be playing back as I expect, but I can’t seem to figure out how to override this behavior with rules. Unfortunately the documentation is fairly non-existent for these specifics.



Very well, I’ve set up monitors and checked things diligently. Without question, if you have a legato technique, the node is entered into the playback interpreter with the first note of the slur (a tick before the note plays), and does not stay for the last. It leads to weird interpretations. Traditionally, the first note of a slurred phrase should have attack at the start of the note…such as brass going Ta (rather than da), while all subsequent notes under the slur get the lighter attacking articulation (da, or la).

Yes, you can stack articulations, such as legato+staccato, but for now, it’s still leading to some strange interpretation issues.

Still, in further reference to your issue, legato is a sticky technique. The legato node remains as long as that slur is on the page (other than the last note where the slur ends).

If you are using Dorico Pro, options include making your own alternative slur mark that will show up on the page with some other technique, without having any expression map nodes assigned to it, and use that instead. With Pro, you can also make subsequent sets of complimentary techniques to apply to each note in the phrase as required.

Just my experience…but without some scripting magic in your instrument(s), or manually moving a bunch of stuff around on the page for the sake of playback interpretation (shift all slur marks start and end points one note to the right), it’s best NOT to have ANY techniques in an expression map bound to the plain “legato” node (OK for things like legato+staccato, but not legato by itself). Let Dorico do the general midi method of interpreting legato. Hopefully this will change in future versions, but to me, legato node handling with the expression maps are not right as currently implemented.

I have no idea which library your using, but if you have a legato patch, you should not use note length for it, the library’s script will handle it. I have the impression that your legato triggers off with short notes because your telling dorico to use other patches for them. So use note length only for non legato patches.


I’m using LA Scoring Strings, so the patch for Legatos and Sustains is one and the same. In addition, the Tremolo and Trill patches also are legato-enabled. There is no library script to handle playing a short (i.e. staccato/spiccato appropriately) from a legato/sustain patch, so I was looking forward to taking advantage of Dorico’s intelligent Note Length feature in expression maps. If I set rules, however, for “Natural” playing type in regards to Note Length, shorts are triggered regardless of slur markings.

I understand if the way I have this configured is what leads to it working this way–I just need to better understand how to configure my expression map to do so, and with the lack of documentation I’m coming here for help. For instance–there is a “Non Legato” option, which I was hoping would allow me to configure the Note Length conditions, but it seems that the conditions are only available for Base techniques, and not add-ons. It also seems like mutual exclusion groups can’t specifically apply to a Note Length condition-based technique.

I can “get around” this by creating a base Legato technique in my expression map, but it does force me into notating alternatively to get legato+tremolo or legato+trills playback to trigger, and was hoping the days of these workarounds (I am also a Finale user…) was behind me. However, it does seem closer than ever before and I am truly loving what Dorico has to offer!

Let me know if anyone else has any ideas! Appreciate the help :slight_smile:


My understanding is similar.

Once that ‘legato’ node is triggered, note lengths are ignored.

You can use stacked combo-technquies from there to force short articulations from your instruments, but my understanding is that Dorico now ignores note lengths in the default playback settings.

Things have been improving with each Dorcio update, but for now I’ve found it better to just strip legato techniques from expression maps unless your target instrument has in depth abilities to better sort articulation options, capture and delay events, and so forth.

By avoiding the legato technique in your expression map, Dorico should fall back to using the note lengths applied in the default playback settings.

If you come across a passage that needs special attention in terms of triggering alternate articulations in your instrument via key-switches/pedals/whatever, make a new playing technique for slurs, assign it to a fresh new technique node (mylegato), perhaps even as a note instruction, rather than a stave direction, and stack it up so it behaves as intended on play-back when you use it in a score. More or less, avoiding assigning the legato node to anything in expression maps until it’s behaving better.

This is what I was hoping would happen by default, but it seems to only be the case if you expression map has a legato technique.

Exactly, and unfortunately this triggers staccato patches within legato lines, hence my issue :laughing:

I know it’s an interesting situation, and I’m also sure that this is not behavior that would always be needed depending on the library.


I feel your pain. I can see the framework developing in Dorico to meet or even exceed our wishes. It’s simply not quite here yet.

I could write a small book about issues and wishes as I’ve studied this issue pretty deeply, and even built a few instruments specifically to work around it (and they introduce yet more issues that I can’t address without tempo and time signature information into the plugins).

Honestly, give this a try.

Make a back-up of your expression map at the end point of the problem stave(s).

Go through your applied expression maps and strip out all the legato entries. Leave everything else alone.

Open playback preferences, and give legato notes a value of something like 105 (or even more if it’s a really lush piece).

See how that works out for you.

I see…

In this case…I assume you want a legato phrase, and for any articulation marks living under the slur to be ignored?


Yes, pretty much; there might be an accent mark under a slur, but not planning on needing to notate staccato under the slur (no violin section jete right now :laughing: )

I do too; in all honestly I’ve had to do worse workarounds to get “well-articulated” playback from Finale (such as assigning short patches to measured tremolo and using harmonics or another technique to now trigger unmeasured tremolo…assuming I don’t need harmonics too :laughing: ) so the sheer fact that Dorico will allow me to do less of that is wonderful, even if there is still some tweaking needed. Plus, notation-wise it’s so much easier to get a beautiful score! :smiley:

Thanks again for your suggestion.


In that case, maybe try:

Have a legato entry in the expression map, but just assign it to your normal nat sound.

duplicate it with the problem nodes added in the expression map.

So maybe you’d have several entries all assigned to your normal attack/sound with nodes

Just in case you don’t know, nodes can be stacked in the expression map editor by holding ctrl while selecting more than one.

Have a look in the play tab. For each node, there is a way to make it display all the active nodes on the timeline. If they have an astrix in there it means it’s a combi or stacked technique. Hovering the mouse over it will show them all.


I think that might be exactly what I need!! I will go ahead and give this a shot; I did not realize that you could stack nodes. Where (besides here) could I learn/read more about these details? The online docs seem somewhat light.

Thank you so much for helping me with this. I had a feeling there was something Dorico could do, and glad to see there was!


I think this is where your problem lies. The minute Dorico encounters a short note, is switches for legato to natural where you specified note length settings.
Natural technique should be used as a default patch and as a way to set the counters back to zero. You should not set up anything in it, except your volume control(s) and maybe some default settings for midi channels you might be changing with other techniques.Natural should be linked with the basic articulation for the instrument (let say détaché for strings).
Then if you want to use this basic articulation (détaché) with note length with maybe staccato and spic. for short and really short notes, you can create a writing technique for it (détaché) that you’ll need to write down in your score and hide as necessary.
If I’m right, you should then be able to set your legato articulation with note length without problem.