Note spacing bug?

Ok, I think I found a strange little bug.

In the attached project, select the last flow and use note spacing tool. Click on the final handle and try to use Ctrl-Alt-right arrow to make the system wider. Doesn’t work for me.

Now, try Alt-left arrow. It jumps to the end of the frame…

Ch 3 NEW.dorico (981.2 KB)

In Layout Options > Note Spacing, have you tried unchecking “Only justify final system in flow when more than x % full”, or changing the % value?

That’s not it. In this project I’m intentionally not doing that, and only widening to taste. This is the only flow that is acting strangely.

Just some observations:

Changing the setting of “Only justify final system in flow when more than 90% full" to 60% changes the final system in flows 1, 19 and 53 to full width. Other flows seem to be unaffected at 60%. I have not tried other values.

If you change the value to 60% and then move the end of the system in flow 53 to where you want it using the final handle, it stays put if you change the value back to 90%.

Also, I have noticed that flow 27 is before flow 26.

I think it’s just a boundary condition. Dorico thinks that the system is already full width, so it won’t lengthen it, but once you shorten it, it kicks into life. I’ll stick this on my list of things to investigate on a rainy day (but there are a lot of things already on that list, so don’t expect us to do anything about it in the near future).