Note spacing confusion - Need help

I am having a hard time understanding exactly what Dorico does during note spacing. In the following picture, what I want to accomplish is to reduce the width of the multi rest by about 50% (or more) while increasing the width of all the other bars each about the same amount to spread them out evenly. Nothing I have tried so far comes even remotely close to my desired outcome. Can somebody help, please? What should I be doing to achieve the desired result?


I think you can achieve your goal simply by clicking the top right square, alt-left arrow (cmd-alt-left arrow to earn some time) until you’re satisfied. Done.
PS: so proud I came out with the solution before Leo :joy:

1 Like

Grab the handle above the last barline on the system, and type Alt-Left (or Cmd/Ctrl-Alt-Left). This should pull everything to the right.

This is perfectly logical but slightly strange at first glance: you’re effectively shortening that bar, and Dorico widens everything else to fill the space. This is a slightly special case, in that the end of the system is governed by the square handle underneath the last barline. Shunting that left would shorten the whole system, and Dorico would compress everything accordingly.

Many thanks, that worked.
Just to check, If I wanted to increase the width of just the last measure it looks like I would need to select every square except the last one and alt-left on the group. Is that correct?

No. Grab that same handle - the one above the last barline - and (Cmd/Ctrl-)Alt-right to widen that bar.

1 Like

OK. Funny, I thought I had tried that and had it not work but on rechecking it, it works perfectly.

I see what I did before. I had a different final measure with some notes in it and when I alt-right moved the handle all the notes in the last measure shifted left equally.

In the following picture, is there any way to decrease the size of the multi-rest while proportionally increasing all the other measures and the note spacing within them?

There are a few general settings for minimum and maximum width for Multibar rests in Engraving Options ⟶ Rests that may be of interest.
But you can compress the rest locally in your example, by selecting (in the note spacing tool you already have selected) the square handle above the right barline of the multirest and pressing Alt-Left arrow (option-arrow on Mac) to move it to the left. Press ctrl-alt-arrow (cmd-opt-arrow on mac) for bigger steps. The rest of the system will take more space automatically, and proportionally.
The square handle will turn red to indicate the manual adjustment. To remove the adjustment, select the red handle and press delete.

I’ll look into the first suggestion but the second one does not work. That shrinks all the measures to the left of the handle and I want to shrink ONLY the multi-rest.

OK, After changing the minimum size of a multi rest, the local compression did work. Apparently I was trying to compress a multi-rest beyond Dorico’s minimum width and it wouldn’t let me. Thanks @PjotrB .