Note Spacing Stress Test

Bart Ruffle’s blog has a great example how different notation programs handle note spacing.
Notably, the old MS-DOS-based Score used to be unbeatable.

Now, see how Dorico handles it.


The excerpt below uses no manual adjustments, except for:

  • the tuplet number in bar 2, to show ratio
  • the first group of triplets in bar 3, to include the rest in the beaming group
  • the slur in bar 3, where I turned “Tucking Index” to 0, in order to avoid collision with a triplet number.

Some settings have been changed from Dorico’s default. E.g. beam settings.
I tried adjusting the “Gap after initial clef”, it doesn’t seem to work though.

The result is impressive. It looks like we have a new king!
Congratulations to the Dorico team.

An updated test including changes discussed in the thread below:

Nicely done, Sugar! I wouldn’t expect Dorico to do any less of a fantastic job!

There are a few places that aren’t identical to the original comparison (i.e., missing/added accidentals), so it would be nice to see those corrections (not that I expect much to change, but you know). Since the samples on Bart’s blog is a bit old now, it would be interesting to see how all the latest versions of the apps would do. I know that MuseScore has come a LONG way since 2012 (was v1.2, is now v2.1). LilyPond has improved a bit, too, since then (was v2.12, is now v2.19). I couldn’t tell which version of Sibelius was used, but it’s bound to be dated (v6 perhaps?).

For me, the only thing I don’t like is how the slur in bar 3 goes between the triplet number in the top staff and the beam it’s connected to. I think it makes more sense to have the slur go on the outside there. In the same triplet, however, I’m very impressed that the final chord is not horizontally displaced by the lower of the two sharps and the previous note almost colliding. That’s a nice touch!

Since the examples on Bart’s Blog are not identical, I focused on replicating the Score version.
What did I miss?

I agree about the slur in bar 3. The only reason I left the triplet number below the slur was that I wanted to avoid trimming a slur manually. I couldn’t find a way for a slur to avoid collision with a tuplet, but there was an option for a tuplet number to avoid a slur (“Tucking Index”).

You only missed a couple of things (except for the vertically displaced “3” that I mentioned before), compared to the SCORE version, both accidentals in bar 3, upper staff.

  1. In the 1st triplet, last note, there’s an added natural.
  2. In the 1st of the very large chords, there’s a missing sharp on the C note, right in the middle of the chord.

Now that I think about it, I recall doing this exercise with an earlier version of Dorico and found it putting (or removing) accidentals all over the place that I didn’t want as it considered notes in other octaves. Not sure if that’s why they are there in yours, but simply forcing an accidental to be displayed/hidden on those notes should do the trick.

Also, I wondered if you needed to change the vertical position of the beamed rest or if it was moved down automatically? In my earlier attempt, it was not, so the stems on the other two notes got extra long. Yours looks great, which is why I’m asking (and since I haven’t had the chance to test it myself).

Here’s an updated version with corrected accidentals and the triplet number in bar 3 at its natural, colliding position.
A manual trimming of the slur would easily fix it.


I didn’t alter the position of the rest in bar 3. It jumped down once I forced a stemlet beam.
See the attached Dorico file.
Dorico Note Spacing Test.dorico.zip (231 KB)
I still couldn’t find a way to make a beam flat or to increase space after the clef (this one looks like a bug).

That looks great! Even the very slight collision between the triplet number and the slur isn’t so bad, but a little breathing room would probably help a little.

Are you sure you looked through the engraving rules for beams? I’m almost certain (not being at a computer with Dorico installed at the moment) that there are several settings to get what you want. There are general settings for how many spaces beams are allowed to slant, given how far apart the first and last stems are, and a general slant/flat setting for long runs of notes connected with a single beam.

And which clef did you want to increase the space after? I think they all look just fine the way they are.

I wanted to make a selected beam flat without changing the general settings.
I don’t think there is a setting for beams which begin or end over a rest.

Tried to replicate the slightly wider gap after the clefs in the SCORE example.

Notation options -> Beam grouping -> Stemlets

there’s nothing there that relates to beam angles.
E.g. if a beam starts or ends over a rest make it flat

Sorry, I misread the question

You should nevertheless be able to make the beam flat by way of the Properties panel.

Can you elaborate?

I can manually change a slant in Engraving Mode. I don’t see an option in the Properties Panel to make a beam flat.

Set the ‘Beam direction’ property to ‘Flat’ rather than ‘Up’ or ‘Down’. This property is found in the Beaming group of the Properties panel in both Write and Engrave modes.

this is so useful, thank you Daniel.
Here’s an adjusted excerpt. I also used a “beam direction” override on two long beams in bar 1 & 2.