Notehead playback assignments are not working

I have setup a percussion template specifying the note # and playback technique (stick click).
I have assigned that template to an endpoint containing the desired instrument (snare).
I have assigned that playback technique to a notehead.
I have written some notation that uses that notehead.

In this case it is a large “X” used to denote a stick click for the test.
When I play back the notation, I only get the default sound (basic hit), as it does not switch to the stick click.

I have double, triple and quadruple checked each of these stages and the proper note number as well as playing the sound on a controller to confirm the “click stick” sound.

I made another map with the intention of setting up a stick click on that notehead, but that also doe snot work.

Assigning different sounds to the tremolo, staccato and tenuto markings work as expected.
The different noteheads do not.

How are you inputting the notes? On percussion staves, you should be switching playing techniques by using Shift-Alt-Up/Down. My suspicion (particularly given your recent thread about how to access notehead sets) is that you’re inputting regular notes and then changing the notehead.

Say what now?
So let me get this straight.
Putting the rhythms in first, then selecting the noteheads I want is a “user error” in this program?

I wouldn’t have put it in quite those terms, but that’s the essence of it. See the procedure on this page of the manual.

I’m not pulling punches anymore.
After encountering bad design issues in this program repeatedly, I have to say this is outright dumb.

A few things here-
A) I am not using a percussion “kit”, I am only using one instrument.
B) Using Shift-Alt-Up/Down is doing nothing (either on selected notes or using the note input caret).

If ALT+up/down-arrow is not doing anything, you have things set up wrong.

If you’re in note input (with the caret active), it’s Alt-Up/Down to select other playing techniques for subsequent notes you input. That page has an error there - I’m correcting it now (well, both worked in 3.1 but only Alt-Up/Down works in 3.5).

Outside of note input, it’s Shift-Alt-Up/Down to change the playing technique of existing percussion notes.

Absolutely none of those options you describe are working for note input of percussion techniques in my score.

All of the techniques I assigned in the drum map are connected to playback techniques which are connected to player technique notation.

I have instructions like “snares on”, “soft mallets” as well as articulations and ornaments working. Roll playback = unmeasured tremolo and using staccato markings for a dead stroke playback work. Those all play back correctly when notated. The intended samples are sounding.

Alternate noteheads, when notated in the score are not changing the playback technique.
Alternate noteheads or techniques are not appearing using the instructions you have listed.
I have tried multiple times on multiple percussion instruments.

If you could zip up a project that’s causing you difficulty and attach it here, I’m sure somebody will be able to get to the bottom of the problem quickly.

Sorry to hear that, it was working for a snare drum for me in 3.5, both within a kit and separately. It might be helpful if you can share a zip of your project in case there’s something specific?

If you’ve “overridden” the noteheads by changing them using Edit>Notehead… then you might need to reset them (Edit>Notehead>Reset to Default Notehead) in order to see the underlying notehead change.

The .zip file is too large. Email?

Hello? I’ve got a Dorico file here zipped and waiting.

It’s after midnight in London…


Can you please email (or WeTransfer etc) the file to me, please, and I’ll take a look?
My email is j.barron at steinberg dot de


I get my Dorico file back from John Barron with the notification that it has been “corrected”.
The sounds for Rim and Stick click do play back now, but nothing has changed in appearance, nor has anything changed in my technique assignment.

Again, assigning the noteheads to the desired playback techniques and changing the noteheads using the “Edit” menu in Write mode (note Engrave mode mind you!) I am told is the “wrong way”.
Go figure that design.

Now, what is it I am being told repeatedly is the right way to assign these alternate noteheads?

Alt+Up/Down for note input


Shift+Alt+Up/Down when selecting a note outside input

Well, as I mentioned before, those methods aren’t working.
Neither of those directives yields any result when I use them.

Let’s investigate. What does the manual say?

Note the sentence highlighted in blue.

Now, here is what I get when highlighting a single note in Write mode on my percussion instrument (and this is on the “corrected” version which was sent back to me that is supposed to contain the proper noteheads):

But “Sn. Dr.” Is not a playing technique.

“Natural”, “Rim” and “Stick Click” are playing techniques.

Let’s investigate further. Let’s look at key commands:

Well, searching “Alt+Up” or “Shift+Alt+Up” did not bring back any results pertaining to percussion techniques or noteheads.
Those do not seem to be assigned as I am told they should be.

Let’s continue the search. Steinberg has a Key Commands guide under “Help”.
We can search key commands containing “Alt” and “Shift+Alt”.

There are three possibly relevant categories to search: “Music Editing and Navigation”, “Step Input” and “Write”.
Here they are:

Step input