Noteneditor: Fehler beim Notenverschieben vom oberen in das untere System

Im Noteneditor gibt es ja die Funktion “Zum Notensystem verschieben … > oberes bzw. unteres System”, was für die bessere Lesbarkeit bei zweizeiliger polyphoner Darstellung sorgen soll.

Leider funktioniert das in Cubase 11 nicht (mehr?).
Statt die Noten vom oberen in das untere System zu schieben, werden sie viel weiter nach unten verschoben, in das nächst folgende System.
In der Hoffnung, dass dieser Fehler demnächst gefixt wird, habe ich hier mal ein Beispiel dokumentiert:

Hier der Ausgangszustand, die zu verschiebende Note ist markiert:
Note vor Verschieben.png
Nach dem Verschieben befindet sich die Note nicht im unteren System, sondern im nächst folgenden:
Note nach Verschieben.png
Ich wollte mal nachschauen, ob das ein neuer Bug von Cubase 11 ist und habe das Prokjekt probehalber mal in Cubase 10.5 geöffnet.
Leider ist der Noteneditor nicht abwärtskompatibel, so dass ich die Frage nicht beantworten kann.
In Cubase 10.5 sehen die gleichen Noten so aus:
Noten in Cubase 10_5.png
Wenn ich hier (in C10.5) die Verschieben-Funktion aufrufe, ist die betreffende Note ganz verschwunden :astonished:

Hallo PAT,

Ich kann den Fehler hier (zum Glück) nicht nachvollziehen, alles funktioniert wie gehabt. Ich habe allerdings C11 auf einer neuen sauberen Windowsinstallation neu installiert. Die alte HD war sowieso zu klein geworden und da bot sich eine frische Installation an. Will damit sagen, vielleicht sind die Preferences schuld?

Abgesehen davon macht es Hoffnung, dass der Noteneditor ein paar (sogar nützliche!) Updates bekommen hat. Wenn sich jetzt noch wieder Custom-Akkordsymbole wie einst in C6.5 als Presets speichern lassen (so ab C12 oder 13) und die enharmonische Verwechslung von His/Ces , und Fes/Eis wieder funktioniert gibts ne Flasche Schampus …

Gruß Thilo

Also bei mir ist die Note zum richtigen System verschoben.

Danke Euch!
Vielleicht liegt es bei mir daran, dass ich zur besseren Lesbarkeit der polyphonen Stimmführung im oberen und unteren System jeweils 3 MIDI-Kanäle nutzen möchte (muss). Das werde ich evtl. nochmal näher checken.

Hallo PAT,

du hast recht mit 3 Stimmen im oberen System funktioniert es nicht. Probiere mal eine 4. Stimme zu aktivieren (ich habe es mit MIDI-Kanal 16 getestet). Die Anzeige der Pausen der 4. Stimme kann man ja ausschalten. Damit hat es dann bei mir wieder funktioniert, d.h. alle Noten der anderen 3 Stimmen ließen sich wieder ins untere System verschieben.

Gruß Thilo

Hi Thilo, super, das probier ich mal.
Ein Bug ist es trotzdem.

Da hast du recht. Ich glaube nur, dass hier kein Steinberg-Mitarbeiter mitliest und der Bug auch sicher nur von ganz wenigen Usern entdeckt werden wird. Das beste wäre, du meldest ihn direkt an den Steinberg-Support oder im zumindest im englischen “Issue”-Forum. Ob die Beseitigung dieses Bugs allerdings weit oben auf der Prioritätenliste stehen wird wage ich zu bezweifeln :wink:

Mal sehen. Ich denke schon, dass sich hin und wieder ein Steini hierher verirrt.
Dieser Bug wurde damals auch recht schnell gefixt:
https://www.steinberg.net/forums/viewtopic.php?f=287&t=175134&p=932726#p1005106

Nachdem ich mir die Sache nochmal näher angeschaut habe, folgende Ergänzung:
Der oben beschriebene Bug hängt wie schon vermutet mit der Zuordnung der MIDI-Kanäle zu den polyphonen Stimmen zusammen.

Zur Verdeutlichung habe ich mal ein simples Beispiel mit 5 Noten erstellt, alle mit unterschiedlichen MIDI-Kanälen von 1 bis 5.
Der erste Takt ist in den folgenden Bildern “normal” dargestellt, im 2. Takt wurden jeweils alle Noten vom oberen System nach unten verschoben.

Wenn die Noten im oberen System den Kanälen 1…4 zugeordnet werden, ist alles in Ordnung:


Im nächsten Beispiel sind den Noten im oberen System die Kanäle 2…5 zugeordnet, der Bass hat den Kanal 1.
Hier kommt es zu dem eingangs beschriebenen Bug.

Inzwischen habe ich herausgefunden, dass man den Bug unschädlich machen kann, indem man alle Kanäle in den Einstellungen anschaltet.
Dann ist die Darstellung wieder in Ordnung:

Hallo PAT,

Danke fürs Ausprobieren. Mehr als 2 Stimmen schreibe ich zwar sehr selten, aber wenn, dann ist es umso schöner zu wissen wie es klappt :wink: .

Gruß Thilo