Noteperformer 4 -> internal mixer in Dorico

Dear all!

It’s a pity that the internal mixer in Dorico is not used by Noteperformer 4… Will this be implemented at some point?


See, it’s not a matter of Dorico but that of NotePerformer respectively any VSTinstrument.
The maker of NotePerformer decided to use their own mixer and only present one stereo output to the hosting application (in our case Dorico). So to Dorico a plug-in is just a black box with a number of input or output ports and it has no control over it.
If you want that behaviour to be changed you need to approach Wallander Instruments (the maker of NotePerformer).


Thanks for the explanation, Ulf!
I would be nice if we could somewhere configure Dorico to always create new instances of certain instruments instead of reusing existing ones.

Especially now, as the makers of Windows 11 in their Eternal Wisdom decided to combine all windows of one application and hide them behind one single icon in the task bar, having the NotePerformer mixer windows open is an additional burden to every Windows user, and being able to user the Dorico mixer as intended would resolve this easily.

I understand your point, Estigy, but you also put a much higher burden on your system with it.
So e.g. one NP instance with 16 instruments is much more efficient than 16 NP instances that each just process one instrument. That’s why we use by default the multi timbral facilities of VSTinstruments.

Isn’t this exactly what @David_Tee achieved some months ago? I mean, it’s my default playback template since then ! Unfortunately, it does not work with the new NPPE… But when using NotePerformer only, it’s a game changer (reverb, compressors, EQs… real mixing available)

This is how I’ve seen the Dorico and NP mixers perform before I installed NP4, but now I’m seeing a full instrument list in the Dorico mixer and in the NP mixer instances. Unfortunately, I’m also seeing that changing the Playback Template (in my case, to Silence and back to NotePerformer) causes all of the faders in the Dorico mixer to get zero’d out. Returning them to a level of 0db makes everything work again. Is this something anyone else has seen?

Hi @dnedwek, in the Dorico preferences dialog on the Play tab (I think) is an option for the default fader level. You can set it there to any value you prefer.

1 Like

Thank you for pointing that out, Ulf.