NotePerformer and other VST sync/timing issue

Combining NotePerformer with the Sforzando player (Vengeful Strings libraries) causes the playback between the two instruments to be out of sync, to the point of being unusable. Sforzando sounds come much earlier than NP sounds. If I set a ‘playback start offset’ of around 150 for every note in the Sforzando instruments, this is resolved, but then the swing indications don’t play back correctly any more.

Is there an easy way to fix this? A setting for a default latency for a VST instrument?

Dorico does not yet have a global track delay setting like Cubase but does include the MonoDelay plug-in which can be found in the Inserts drop down. Just apply this to the tracks which come too early by the appropriate number of ms – Google Steinberg MonoDelay for details on how to use it.


Thank you @dko22 ! That works. For others, these are the settings you have to make. Note the ‘sync’ switch inside the Delay button that should be turned off to input an absolute time in ms:
Screenshot 2023-03-07 at 13.22.38

1 Like

absolutely correct! It is in the instructions but it confused me when trying to run the thing without looking at them and is worth mentioning. Also feedback to zero. Glad you’re sorted, anyway.

1 Like

There are also the Free excellent Voxengo plugins, Sound Delay Plugin and Latency Delay Plugin.


1 Like