NotePerformer not outputting sound in Dorico 4

Hi!

For reference, I have just updated to Dorico 4, but this was a consistent issue when I was on 3.5 as well. I am using an M1 Mac running Monterey 12.2.1.

My issue is that NotePerformer is not producing audio. I am not sure whether the problem is that it is not assigning instruments for playback or something else.

The playhead moves, but no sound is coming out. I am able to get sound if I switch the playback template to one of the HSSE templates, but not when it is set as NotePerformer.

My default playback template is set to NotePerformer, I’ve manually checked that it is set as the playback template in Play Mode. I’ve reset the playhead to the beginning so that it would assign sounds. I’ve manually hit “Load Sounds for Unassigned Instruments.” I’ve updated Dorico as well as my OS. I’m at a loss at this point.

NP is not yet updated to use the native M1; you need to run Dorico 4 in Rosetta to access NP.

1 Like

I have the same issue with NotePerformer trial on an Intel-based iMac.

start by reapplying the NotePerformer playback template and if necessary close/restart Dorico. That fixes the majority of such problems – if not report back.

@Ralph_Johnson , adding to what dko22 wrote, when still no sound comes out then please choose, while that NP project is loaded, from the Dorico menu Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

Tried dko22’s suggestion—same result. Attaching the Diagnostics .zip file here.
Thanks!
Dorico Diagnostics.zip (805.9 KB)

Thanks for the data, @Ralph_Johnson.
NotePerformer got blacklisted with you. During start-up the so called vstscanner loads every plug-in it can find and performs some basic tests with it. If that fails a plug-in gets blacklisted and disregarded on every further start-up.
From the data I can’t see what version of NotePerformer you have. Can you please go to /Library/Audio/Plug-Ins/VST/, do a right click on NotePerformer.bundle and choose GetInfo and check what version number gets displayed there? The most recent version is 3.3.2.

Please also do the following:
Open a Terminal window and do

cd /Applications/Dorico 4.app/Contents/Applications/VSTAudioEngine5.app/Contents/Components/VSTPlugManager.bundle/Contents/Resources

followed by
./vst2xscanner -p /Library/Audio/Plug-Ins/NotePerformer.vst

What does happen? Please copy and paste the output of the Terminal window.
Thanks

I don’t know if it is of any help but I had a similar issue on my MacBook the other day and fixed it by going to Preferences → VST Plug-Ins. There I pressed Clear Audio Engine Cache and Reset Audio Engine Data and restarted Dorico. Since that Note Performer is producing sound again.

that used to be a very common fix with Dorico 3.5 (I had the same issue quite a while ago) but I thought that the issue of blacklisting for instance was largely a thing of the past with Dorico 4. Obviously there are still some that get through the net but Ulf can usually get to the bottom of these pretty quickly.

NO sound on the PC.

Welcome to the forum, @ye_xihui. Please refer to the Dorico playback troubleshooting video: