Notes duration are uneven in MIDI and playback modes


After hearing that the playback rhythm is jittery, I looked into the PLAY mode and saw that the duration of the notes is uneven. Do you know the source of this problem?


Did you enter the notes with MIDI Note Entry?

Do the notes have Playback start offset and Playback end offset values in Properties pane? If so, select all notes (use the Filter just to select Notes) and then turn the switches off for those properties.

Thanks for your reply!

I entered notes on WRITE mode. Playback start offset and Playback end offset are off.

Can you attach the project itself so we can take a look?

test.dorico (545.1 KB)

By default, this Playback Option (Ctrl/Cmd-Shift-P) is set to 50%. This allows some randomisation of velocity in order that playback better mimics human players. Set it to 0% and you’ll find that every note is attacked with the same velocity.

Thanks, @pianoleo!

The problem didn’t relate to dynamics, but it did, apparently, to another humanize function

Now it’s perfectly even!

I have another quick question - I hope it’s okay to include it in this thread:

I’m exporting a series of excerpts for an experiment. Is there a way to avoid long silence at the end of each track? Is it possible to choose the name of the file?


There is a preference value for the amount of time to leave for a reverb tail when exporting audio, but as yet it doesn’t appear in the user interface. However, if you’re not afraid to get your hands a little dirty, you can change it yourself.

First, quit Dorico. Next, find your preferences.xml file in /Users/your-username/Library/Application Support/Steinberg/Dorico 3.5 and open it in your favourite plain text editor. Then look for this section:


Change the number in the tag to another whole number (integer), e.g. 1 or even 0. Save the file, and restart Dorico.

You can’t control the filenames used for audio export directly in the app at present, though we do plan to add further functionality in this area in future.

1 Like


On my Windows 7 machine, the preferences.xml file seems to be located at a different address:

C:\Users\username\AppData\Roaming\Steinberg\Dorico 3.5\Preferences.xml

For what it’s worth, I found that the “value” field can also accept negative integers (eg, “-1”). A “value” of “0” adds a silence of approx. 2 seconds; a “value” of “-1” adds a silence of approx. 1 second.

Please let me know if I’m doing anything incorrectly here!


You shouldn’t use negative values; use 0 for no additional reverb tail, though there will still be what you might perceive as silence at the end of the file because the file will not stop until the precise end of the flow.

Thanks, Daniel.