Notes sticking or not sounding

stickingnotes.dorico (537.1 KB)

I have a score for organ here, using Hauptwerk for the organ sounds. I suspect my problem is in Dorico though, rather than Hauptwerk.

In the score, there’s a crunch chord in the left hand, on the swell, and then the great plays some of the same notes in the right hand one after the other while the chord is sounding. What I’m finding is that notes that are already held in the left hand sound in the right, but then stick, and they don’t release till they’re released in the left hand.

I don’t fully understand how the separate manuals are implemented but my understanding is that they ought to be able to be completely separate.

Come the third bar, the LH chord changes and all the RH notes that had stuck get released. Now though, the RH has a D and the left hand has a D a beat later. That second D, in the left hand on the swell, doesn’t sound.

Finally, bar 5 has an F on the great in the RH, which is fine until bar 6 arrives, which has the same F sounding in the LH on the swell. When that note arrives, the RH F is cut short, though it is played on the swell.

Anyone have any insights? Thanks :slight_smile:

Are you sending the notes from the separate manuals on different MIDI channels even if (some of) the stops are the same?

Hi Derrek

I’ve got great on channel 1 and swell on channel 2.

That makes sense, but do the manuals point to the same sample(s) or do you use multiple instances of the organ for each manual.

(When you mentioned notes on one manual holding onto notes form another manual, my first image was of a Tracker organ with manuals coupled. I know that is not what you are talking about, but it brought back memories.)

This is really strange. I think it’s because there are some unlisted voices assigned to channels 6 and 7, but I do not know why they are there. The extra voice is causing overlapping notes across voices to be cut off for some reason. However, I have a solution:

  1. Open the Hauptwerk Expression Map and check “Allow multiple notes at same pitch”:

  2. Open Endpoint Setup by clicking the gear next to the Hauptwerk VSTi slot.

  3. Set the number of channels to at least 7 (or just set it to the max of 16), and assign them to the Hauptwerk expression map.

No, the great and swell have different stops on them, and at this point at least the manuals aren’t coupled.

Thanks once again, and for doing those illustrations.

It doesn’t fix the problem in bar 3. Now, the D does sound on the swell and the great, but when the great D is released, the swell D wrongly stops as well.

Okay the problem definitely has something to do with those extra channels being set. We can get rid of them like so:

  1. Change the Playback Template to Silence.
  2. Add a Hauptwerk VST Instrument and configure its channels and expression maps in the Endpoint Setup dialog.
  3. Set all the voices to that instrument and to unique channels, ensuring the Pedal voice is set to channel 3.

This should fix the notes on different voices stopping each other prematurely.

However, tied notes that change voices will be rearticulated, as Dorico doesn’t combine their note events despite being on the same channel. You can fix this by moving the notes to the same voice and adjusting the Voice Column Index in Engrave mode.

(Also, it turns out we don’t need “Allow multiple notes at same pitch” enabled.)

Hm. I’m going to have to find a better way for this particular piece I’m working on. If I do anything to the playback template, like changing it to silence or trying to reuse the Hauptwerk one, I lose all my choral sounds, which are Voices of Prague in Uvi Workstation. Typing every syllable in on their awful UI is painstaking and there is no way to save that data separately once you’ve done it. And if I change the playback template I lose the lot.

If I change to the Silence template, then I either lose the F in that left hand chord or the D, depending on whether ‘Allow multiple notes at same pitch’ is allowed or not. Why the F is compromised I don’t know.

Is it your feeling that this is a Dorico problem rather than Hauptwerk? Is Dorico sending the wrong info down the line, and would it stop doing so if we could remove the phantom channels 6 and 7?

Right, touch wood I think I’ve done it. I’ve left the playback template alone but have created a second organ instrument, copied everything in it from organ 1 with a straightforward copy & paste, and removed organ 1, then set the channels etc in the normal way. My hope was that the phantom channels would not get copied over, and so it has turned out. There are only 5 assigned instruments in my endpoint (which is right for the whole piece I’ve posted an extract from). And it all seems to be playing back ok, though I’ll have to do a lot of careful listening before I’m completely confident about that.

Once again, big thanks.

Jester Musician, do you find that the playing technique for the swell Lieblich Bourdon works? It’s not working for me, either adding or removing.

I’ve tried changing it from control change 38 to 92 (which was unused), but now if I try to take that stop off, it’s the same as doing general cancel. Don’t understand why. Has 38 been working ok for you?

38 does not work for me, but 92 does. However, it looks like 92 is bound to the General Cancel technique.

Try changing this row to Control Change 3, value 0, and changing the corresponding setting in Hauptwerk (which should have been set in step 5 of this post, under Hauptwerk.)

Thanks. Wires now all uncrossed I think. Cheers.