novation automap

I’ve bought a novation sl mkII, to use with cubase 6 elements. I’ve installed automap. I did all the settings like I should but I can get no sound. I made an instrument track, input al midi in, output a vst instrument. I’ve tried record able /enable, monitoring on/off. When I play the keyboard I can see tthe midi activation and when in the key editor I can see the keys I play moving on the piano roll. But no f#cking sound!! What do Ido wrong? The Automap thing used to be very easy.

I hope someone can help me out there cause it’s so frustrating.
Greets from Amsterdam

Anyone out there?

The Novation sl series dös not produce Sound. Its a midi Controller. How can you buy such a thing without knowing what it does??? Cheese…

I know what I"m buying. What I’m trying to say is; there is no sound coming from the cubase instrument track, what goes out to vst synth, when I trigger it with my novation midi controler. I can see cubase is receiving midi information, and when I open key editor I can see the keys I’m playing in the piano roll. But no sound, but when I draw notes in the editor there is sound. Also when I playback. The controler keys works fine by the way.

Have you tried to assign the Novation directly in the track, rather than the All MIDI selection?

What do things look like in MIDI Port Setup? Is the “In All MIDI” box checked for the Novation?

But what is the output of the VST instrument? Check your mixer to see where it goes and compare with VST Connections to see where your audio outputs are assigned to.

The imstrument track goes to stereo out. This connection is ok 'cause in playback there is sound.
When I use the virtual keyboard in cubase or another extern virtual keyboard I get exact the same problem.
midi ports.png

Ah, I missed the part that you do get sound in playback. In that case it’s a monitoring issue. Is the instrument track record enabled (red dot button showing)? And the monitor button (orange speaker)?

Yes, red and orange buttons are on. The monitoring part in cubase seems to be ok 'cause on audio tracks the monitoring is good without using the directmonitor function.

But there is still an SL MKII midi port that is unchecked in “In All MIDI” according to the image you posted.

Yes I’ve tried that one, but no results.
midi setup(1).png
midi setup.png

Sorry I’m a little late, but I solved the problem. It had something to do with the channels in the preference. How silly.
But it works great now.
Thanx to you all
greets from Amsterdam