Novation Impulse - Transport Not Mapping

I can’t get the transport buttons to map on my Impulse. Faders , buttons and rotary’s map but transport won’t. It’s weird because they did it one time but they would not respond when pushed. I deleted the map to start over and I couldn’t add them back to the mapping assistant. I rebooted and they miraculously appeared with exception of the of the record button. I tried to add it but couldn’t… I decided to map the ones that were there but they wouldn’t control the transport afterwards. I’m beyond frustrated. BTW it works fine in CB 5-11 using Automap.


I had that problem with my Impulse as well with my initial attempts. But I found that the Impulse was set to MC for the transport buttons. Changing that to “CC” (push “Setup” on the Impulse and change from MC to CC) did it for me. After that everything worked as expected.

Seems like MC (=MIDI Maschine Control) is not supported by the surface editor of C12. Probably possible via real scripting though, but I haven’t tried that.

I will give that a try. It does seem like CB is not receiving the CC information for transport.
Thank you.

The Impulse was already set to CC. Still no transport.

I notice there are a couple “MIDIIN” ports associated with “Impulse”. I would try setting the midi ports to those and see if the transport messages are being sent there. That’s how it is with my Nektar Impact. It’s actually the same exact name, “MIDIIN”.

It is very possible the transport buttons in the Impulse are using a separate port from the regular midi cc/note messages.

Yes, that did it. I’m sure I tried that before though . I did reinstall the update. Maybe that jumpstarted something. Thank you.

I think the real problem was that automap was installed and interfering with the cc data. I uninstalled and I was able to get it to work in standard mode without hui as well.