Novation Launchkey 49 MK3 not working well in Cubase 13

I am going through the rough start of setting up my first home studio, and I have got a Novation Launchkey MK3 MIDI connected via MIDI cable to my SSL2+ interface, and thet connected to my computer.
I have set it up as instructed in several videos, and it has automatically mapped the Launchkey in Cubase.
But the problem is only the keyboard keys, and the play, record, stop, loop buttons work. The faders, the knobs, the pads are totally non resposive in Cubase. Not only does the built-in mapping not work, but I can not even use the Mapping Assistant as touching the controller has no effect in Cubase.

I am baffled - clearly the MIDI is well connected as I can play it using instruments, even the pads work with that (when i make an instrument track with Kontakt 7 I can play the sounds on the keys and pads).
And still in the mapping it is if those parts didn’t exist!

Clearly the problem must lie in Cubase. At least I think so…

I have the same keyboard and it works well with CB13 pro. If you look at the midi remote window in the mixer/console section at the bottom, you’ll see lit areas where parameter editing exists. If you press shift and “pan” in the buttons section, for instance, you can get the pan knobs to affect tracks. If you press the track arrow keys, you can get movement in “banks” of 8 channels across the console.

I’m not an expert in that regard (midi controlling my DAW) but I’ve learned a few tricks, as well as programming my own keys for vocal recording sessions — like shifting the punch in to beginning of the next cycle marker, etc.

The important thing is to have the connections right and use the default mapping to get a handle on things before you go rogue. :slight_smile: I flailed with this for a while myself. And then it all seemed to fall into place.

Good luck. :slight_smile:

Why do you have the MIDI cable connected to the SSL? If it’s connected over USB to the computer, that’s all you need. MIDI Remote works perfectly fine here with the same controller.

1 Like

I missed that detail. Assumed that he was USB direct into the computer.

PSSST! Don’t do that MIDI thing. Just use USB.

@Monotremata Thanks for the advice, but it didn’t solve it. If I connect the MIDI directly to the computer, the problem remains unchanged, and I get massive latency due to the fact I am monitoring through headphones connected to the interface.
@Roland111 My issue apparently disables the function you describe - when I ckick shif and “pan” nothing happens at all. The faders, knobs and pads in the “MIDI remote” window are lit up correctly, with colors corresponding to the tracks, but there is NO WAY to effect any movement of those - not on the keyboard and not in the MIDI-remote window.

You’re not supposed to “connect the MIDI directly to the computer” - however you are achieving that. You need only one cable to make it work — a usb cable that you plug directly into your computer and the MKIII on the other end.

Do not connect to your interface or any midi device. And don’t use a MIDI cable for anything until you’ve got it working this way.

Then go to MIDI remote and make sure it shows up, the way it does on my computer. I don’t use a MIDI cable unless I’m triggering another external sound module or synth. No need for it otherwise.

1 Like

@Roland111 By “connect the MIDI directly to the computer” I mean exactly what you describe - the USB cable between the computer and the Launchkey MK3. As I said, I tried it, and I get latency ( I have my headphones hooked up to the interface, and I can not get rid of that as i do my vocals through a condensor mic, so the interface has to be there to power the little bugger (I switch between doing vocals and MIDI instruments, so changing setups to headphones hooked up to the computer directly every time would be even more of a hassle than having a half-non-responsive MIDI!!).
I don’t even know if headphones hooked up to the computers jack would solve the latency issue, as I don’t have headphones with the tiny computer jack :sweat_smile:

Do you not get latency, and how do you monitor?

When tracking, I set my buffer to 64 samples or 32 if I can get away with it. That way I don’t get any noticeable latency (or recording offsets that I can’t correct later with a few tweaks).

If I try to record at 1024 or so, I might as well take up another hobby cause it’s impossible to play along with anything. :slight_smile:

@Roland111 I have to have a high buffer (about 265 I think it is) because I use a lot of heavy orchestral plugins, so no choice there to keep it working

But - I found the solution! I just plug in the MIDI both ways - by USB directly to the computer aswell as by MIDI-cable into the interface. I then record choosing the interface input (which saves me from all latency) and the USB has the Launchkey fully operational! (and it wasn’t when I only did the USB!). So now all is well, even my quick controls are working :grin:

Glad to hear that all is right in the world of Cubase. :slight_smile: The advise to record at a lower latency should have come with the suggestion to disarm or render the other tracks into a stereo file so that they do not interfere with your ability to set the buffer size.

I often open a new project with a stereo mixdown just so I can record specific tracks the way that I prefer without being constrained by my CPU power, etc.

Anyway, glad to hear it all worked out for you — and also for the Mods who must enjoy seeing those “solution” notices go up. :slight_smile:

1 Like