NRPN Cubase 13.0.20

I am still getting the hang of how this forum works I think so apologies if I’m doing the wrong thing - originally added this to the end of a closed post.

Not sure if everyone else has this sorted - trying to do a mapping for a Zoom HD16 in Cubase Pro 13.0.20 and I can’t figure out how to do the mappings for the 14Bit NRPN. I hacked an XML script to get it working for Generic Remote before the MIDI Remote functionality was introduced but that doesn’t seem to be working any longer either. I have entered the CC#s that worked in the script but no joy. Anyone have an idea on this?

Update: have logged a support call through Steinberg Australia but they don’t yet seem to have a ready answer. I have reinstalled 12.0.70 and in that I can get both the old-style Generic Remote to work and also the MIDI Remote functionality. Neither is working in 13.0.20. I note that the MIDI Monitor in the Mapping Assistant correctly interprets the 14Bit NRPN controllers in 12.0.70 but does not in 13.0.20. Is there some issue with the way 13 is parsing these MIDI messages? It seems that both versions are working from the same scripts as changes made in 12.0.70 show up in 13.0.20.

Others seem to have resolved this so can someone give me a pointer?

[Additonal - Australia support suggested setting up as Mackie Control. This does work in 13.0.20, but the Zoom has two remote modes and the Generic Remote provides a lot more capability tham the Mackie mode. I have let them know that was not the problem I was trying to solve.]


Mackie Control supports 14bit resolution by using PitchBend MIDI Message (the faders).

Have you tried the following settings in the MIDI Remote, please?

Hi Martin, thanks for your response. Yes I have, this is what is happening:

In Cubase 12.0.70 this is the layout of the MIDI Remote Control Surface:

And here is the properties dialog associated with the fader on Channel 1 at the bottom left:


This is what the MIDI Monitor shows when you move the control upwards:


And this is what happens to the virtual fader in response:



So all working as it should be.

In 13.0.20, here is the layout again (appears to be reading the same script):

Here is the same set of fader properties:


But the MIDI Monitor now fails to recognise the NRPN commands generated by the HD16, instead seeing it as just the two separate CC98 and CC99 commands:


And instead of moving the virtual fader, MIDI Remote Manager sees it as a new control and creates a new knob (or whatever you have selected instead) elsewhere on the screen:


Since this seems to affect both the Generic Remote functionality in Studio Setup and the MIDI Remote functionality, my hypothesis is that 13 is handling the MIDI in some different way at the top level than 12 is. I have looked through Project Settings but can’t see anything that could be causing this?

I thought I would also look at what MIDI Monitor picks up if you route the output from the HD16 direct to a track. 12.0.70 shows this:

And 13.0.20 shows this:

So it’s like the program is unable to see the specific NRPN control messages at all. I have looked as carefully as I can through the options in Project|Settings but can’t see anything to change. However, if this should be working on 13 there must be something in my setup that’s frustrating it. I’m running Ventura 13.6.4 on a 15" 2017 MacBook Pro.

MIDI CC# 640?!
How is that even possible. Or is this tapping into MIDI 2.0?


This is the 14bit value.

1 Like

A bit of further investigation: I didn’t know about the MIDI Monitor functionality that has been introduced under Studio Setup|MIDI Port Setup, but in my instance of 13.0.70 these do not appear to show any activity, even though the MIDI Monitor insert on a MIDI track does. Not sure if this is related.

I’m used to seeing NRPN as two CCs where the where the value of the two CCs combined makes a 14-bit value. The CCs themselves are by design 7-bit (MIDI CC# 1-127).

I believe that in the Generic Remote functionality and MIDI Remote, Cubase is able to do the interpretation to give you the 14Bit CC directly. At least, this is what was working for me previously in Version 12.0.70. It is being transmitted as four separate messages I believe, as per the MIDI Monitor screenshot in my post.

1 Like

Hi, it works as expected here, just tested it. However, I have to note that I used Bome MIDI Translator Pro to send the messages, since I don’t have a device sending NRPN.




Thanks for that. I’m wondering if I need to do a reinstall or at least to clear the config in some way. I might try that to see if it works.

No it doesn’t

Do you by any chance have the generic remote active as well, and/or the Mackie? It seems to me that there is a chance of something in the middle, consuming CCs. And maybe you could post your script, using the export script function, so I can test it here?

Thanks for your attention to this. I agree with your thoughts that something is grabbing the MIDI messages but I can’t figure out what. I have disconnected the Zoom HD16 MIDI ports from the Generic Remote, but it’s still there. Just experimenting in V12, it appears that MIDI Remote takes precedence over Generic Remote - at least I still had Generic Remote connected there and it appeared that the MIDI Remote was working. I have tried deleting Generic Remote (and SKI remote) entirely but that doesn’t seem to fix it.

Here’s the script:

Zoom_HD16.midiremote (8.3 KB)

The script is by no means complete. The first five faders are correctly connected and the first pan. I have also realised that even though the Mute buttons appear fine (in C12), there is cross talk between them so pressing Channel 1 affects 2 and 3 and so on. This looks like a bug. Because I had previously struggled with MIDI Remote, and Generic Remote worked fine, I didn’t persist with MIDI Remote, only coming back to it when Generic Remote wouldn’t work in C13.

For comparison, here’s the XML file for the Generic Remote mapping if that’s of any illumination:

Cubase 11 HD16.xml (188.7 KB)

I did have a look in the Mac Audio MIDI setup, but if something was interfering at the system level, you would think it would affect all versions of Cubase equally. I did also try sending NRPN messages from my M-Audio Axiom 61 which Cubase 12.0.70 can see (in deconstructed form):

But which don’t show up in MIDI Monitor in C13.

[Edit - there was a bunch of stuff here but I stupidly only just realised that the MIDI monitor on MIDI tracks doesn’t show activity unless Record is enabled - doh! Additional: in my defence, I have only just changed the settings so selecting a MIDI track does not enable record so would never have seen this before. Still doh!]

Hi @m.c would you be willing to share your Bome MIDI translator project? i downloaded the trial but as I’m unfamiliar with the tool, struggling to get it to transmit the command.

Hi, sure: (822 Bytes)

  • Unzip this file (Forum’s security didn’t let me upload the original template).
  • Load it inside BMT.

The setup is for sending an NRPN for control (MSB 5, LSB 0) 640, at channel 0 (1) at Bome’s port 1.

I’ve assigned Alt+Ctrl+Shift+P to control value increasing, and Alt+Ctrl+Shift+M to decreasing it (P stands for plus, M for minus).

Let us know how it goes :slight_smile:

1 Like

Thanks a million - will do!

OK, interesting. @m.c here’s what I get from the MIDI Remote Assistant MIDI Monitor in 12.0.70 using your script:

Screenshot 2024-03-16 at 11.17.14 am

13.0.20 does not see any message at all. However, if I change the MIDI out from Bome MIDI Translator to a Note On message it does see that:


It’ s also interesting to me that in your screenshot of the MIDI Monitor, although it is seeing all four of the constituent messages that make up the overall NRPN message, it is not interpreting them as such. In my 12.0.70 it is correctly interpreting it as the NRPN as well as showing the four messages that make it up.

I’m attaching some of my MIDI Settings - the only difference I can see between what’s in 12.0.70 and 13.0.20 is that 13.0.20 includes boxes for Controller display resolution in the Editing-MIDI options:

And in overall MIDI Preferences, there is the provision for MIDI CI, but I’ve unticked that:

Still scratching my head.

Hi, this is because I didn’t use the mapping assistant monitor. In the mapping assistant, it will let you choose whichever of these messages (the complete one or others) you want.

Now, the thing is that I didn’t notice you’re on a Mac. My testing was done on Windows, and everything works as expected.

Today I tested things on my Mac, and you’re right! In CB12 I get the NRPN recognized properly and mappings (obviously) work. However, in CB13 latest version (running either on Silicon or Rosetta), NRPN is not recognized, either send by BMT or by my Novation SL MK3 properly setup in its user mode.

I’m no way an experienced Mac user, to not say I’m a total novice, so maybe, just maybe, there’s something in preferences, a filter or whatever creating the issue. Otherwise, it’s a bug.

Thank you so much! Really appreciate your effort on this - good to know I’m not alone.

Also thanks for the steer to Bome MIDI Translator. Building a workaround although I would rather it worked natively.