Nuendo 10 does not run after Windows 10 1903 Update (Solved)

Upon opening Nuendo, the following error shows up :

DCOM connection to program ‘Synsopos.exe’ failed.
Error:Unspecified error

I am using the latest eLicenser Control Center which is currently 6.11.6.1251. The eLicenser Control Center does not run either.

Works fine here. Make sure you have the latest version and run it as administrator and then do maintenance.

I uninstalled elicenser and then reinstalled.

Now, it opens with one problem and one mystery.

Problem : groove agent not playing on existing projects. But when I add a new groove agent instance, it plays. But my old sounds are gone somehow.

Mystery : elicenser control center doesn’t install its latest version. Even if I downloaded the latest version twice, it automatically installs an earlier version instead of the latest version.

Run the elicenser as “administartor”. Choose to repair.
If this doesn’t help, run Nuendo as Administrator.
Worked for me after the update.

Tried all that but mysteriously enough, regardless of how many times I download and install the latest version, it automatically installs the version 6.11.6.1249. I can not install the latest version of 6.11.6.1251.

Have you tried uninstalling the update run Nuendo 10, see if it works and then reinstall the update, see if it works.

https://www.techadvisor.co.uk/how-to/windows/how-uninstall-windows-10-updates-3682074/

Hello everyone, I am happy to inform that after installing the latest version of eLicenser Control Center which is 6.11.6.1252, released on June 4, the situation has been resolved.