Numbered bar region not visible (opening file from Dorico 3.5 in Dorico 4)

Hi all,

first of all thank you so much for your fantastic new features in Dorico 4. So many great ideas, one has dreamed of for years!

Unfortunately the numbered Bar region feature does not work for me with files, that I created in Dorico 3.5 and now open in Dorico 4.
I see that there is a reagion, but no numbers are shown. (one can only see the small circles for the edges of the region, but nothing else…?)

Do I have to activate this extra somewhere in the preferences? Or is ist a bug?
When I create a new file in Dorico 4, then it works.

Is this known (I didnt find another post in the forum about it)

Thanks for your help!

Go to the Players page of Layout Options and see whether the option to show numbered bar regions is active or inactive.

1 Like

When opening 3.5 project first thing I do is go into the Library manager and check settings, that’s worked well for me.

On the same topic of numbered bar regions (a feature I love, because I was faking it with text), I wonder why I still get my 1 showing, despite having chosen the option in Engraving options not to show the number in the first bar. Any clue?

OK I wasn’t sure what numbered bar regions was specifically, searching the docs wasn’t bringing it up nor web search. But inferring from above it seems that it’s numbering used for Bar Repeat counts and Slash repeat counts - true? But OP is talking about basic bar numbering, so I’m corn-fused.

Download the 4.0 Version History and have a search of that – numbered bar regions is a new feature that isn’t yet documented in the manual.


Thanks Lillie, I have the D4 Main Docs page bookmarked which doesn’t appear to include that, so I keep forgetting, I’ll add another bookmark.

I think this is a bug, as I get the same result. You can turn it off in Properties though.

1 Like

I think this is a distinction between the repeat-symbol count (which can omit the number and logically omits the repeat symbol on the first/source measure) and the written-out repeat region which numbers the first measure regardless.

Perhaps an additional option is necessary.

I experienced the same issue. Whether it’s a bug or a new option is necessary, it would be great to be able to set that automatically.

This is on our radar and will be taken care of in the first maintenance update.


Thank you Daniel!

Thanks for the quick answer, that solved it!