Numpad dot key not working in Dorico

Anybody else find they have to use the period key on the main part of their keyboard to get a dot during note input? I’m using Dorico 2.1, Windows 10, 64-bit, and I believe the problem occurred using v. 2.0 as well.

It’s not default (I don’t think); you have to map it in Key Commands. Works for me!

Yeah, I did, and it started working. The key commands reference, though, lists the numpad period as mapped to dotted notes straight out of the box, so there’s a discrepancy there (Steinberg team please take note). Additionally, when mapping the numpad period key, a warning appeared that the numpad dot was mapped elsewhere globally (and that this would cause a local override) — no problem, but I didn’t see a way to determine what the numpad-dot’s global mapping was.

To check it, delete the custom key command, and go to Help—>Key Commands. Nifty interactive key map.

I once asked this question. The answer was - as far as I remember - numpad keys O and , (or . ) are mapped to the same functions as in Cubase.
Which is something like Play and Stop (I actually don’t remember exactly), may be someone else could jump in here?

[Edit] here the relevant thread: https://www.steinberg.net/forums/viewtopic.php?f=246&t=133731&p=723703&hilit=numpad#p723703

The Key Commands map on the help menu is generated by your computer automatically. The underlying code assumes that the num keypad keys will mirror whatever’s on the top row numbers etc. So yes, sometimes it lies!

Oh, that explains it. Thanks, Pianoleo. I wonder if this can be remedied in a future Dorico update, or if it’s entirely dependent on the OS and out of Steinberg’s hands?

Dankreider, I did open the key-commands thing (the one in the Help menu) before assigning the custom command, and it listed numpad-dot as “Dotted notes” — hence the confusion.

That’s strange… it didn’t default to that for me.

Was 2.1 your first version? Maybe the update mapped it automatically.

It’s possible. The key-commands settings in Preferences don’t differentiate between Step Input and Notes, but that distinction is found in the Help -> Key Commands map, so that might have something to do with it.

Slightly old thread, but I’m confirming that on a fresh install (doing the trial) the keyboard shortcuts say that the numpad dot should enter dotted notes mode, but doesn’t. You have to use the period on the main part of the keyboard. Same goes for the set accidental commands.

Not to be redundant, but did you map the dot manually in key commands? That’s what you have to do to get it to work.

You haven’t said whether you are on Windows or Mac, but on Windows it makes a difference if the Num Lock key is active or not. Dorico recognizes two different key presses for the . on the keypad: Num+. if Num Lock is on, and Num+Del if it is off.

You can use either or both in key commands, so long as you realize they are different.

FWIW I have set the preferences so that the “Note Input / dotted notes” keycommand set to recognize both . on the main keyboard and Num+. on the keypad - but not Num+Del if Num Lock is off.