NVIDIA & Cubase don't mix well

I am passing on this information which may be useful to some of you.

Since Cubase 12, the display of VSTi Padshop, Groove Agent, HALion, The Grand, etc. have started to flicker randomly when Cubase is in Play mode or when I play on my controller keyboard for the current VSTi. It’s pretty mind-blowing.

I asked technical support and Yamaha Canada who guided me to find a solution to this problem (Thanks to them). Of course, the problem of this flickering, to say the least, was related to my NVIDIA GeForce GTX 1650 graphics card. After downloading the latest drivers for the card, I was suggested to go to the NIVIDIA control panel and activate ‘Prefer maximum performance in power management mode’. I never found this option in this control panel. However, in the GeForce Experience application settings under the General tab, I enabled the ‘Image spatial scaling’ option and oddly enough, there is no more flickering of the VSTi since then.

What is the link between the flickering of the VSTi and this option? No idea and Yamaha could not answer me either, except that Steinberg was aware of this problem.

This problem has existed since version 12 and continues with version 13.0.40. This problem did not exist for me with version 11. What happened with C12 & C13?

Hi,

Please try this:

  • Download the latest Studio driver version from here. If there is no Studio driver for your graphic card, use the one, which is available and continue with the same steps below.
  • Disconnect the computer from the Internet to ensure Windows will not download and install its graphic driver.
  • Uninstall the NVIDIA driver.
  • Restart the computer.
  • Start the NVIDIA driver installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), and keep the video driver enabled.
  • Connect your computer to the internet.

I have an Nvidia card also and I can reiterate what @Martin.Jirsak says about ONLY installing the basic driver, and NOT the whole Experience package. Works fine here on CB13 + Win11

Yeah, the gaming stuff and the DAW stuff both want to own realtime control of your computer and will bicker over it.

Hello Martin,

I’ve done some testing regarding this issue I encountered and there are some things that are rather difficult to understand.

First, I decided to uninstall the NVIDIA graphics card from Windows Device Manager.
I also uninstalled all NVIDIA applications (Control Panel, GeForce Experience, PhysX System Software, HD Audio Driver, FrameView, Graphic Card).
And I restarted the computer.

Upon restart, Windows detects the existence of the NVIDIA card and activates it without installing any NVIDIA software.

However, after a few seconds a request to install the ‘Control Panel’ application appears. If you don’t do this, this request will reappear after each startup. Oddly enough, with or without ‘Control Panel’, HiDPI enabled or not, with 'Scaling Application or without, Cubase became functional again. No more flickering from Steinberg VSTi.

I downloaded the drivers for my NVIDIA GeForce GTX 1650 graphics card, the file named “555.85-desktop-win10-win11-64bit-international-nsd-dch-whql” and not the one named “555.85-notebook-win10-win11- 64bit-international-nsd-dch-whql”. Using a desktop computer and not a laptop, it was the wise choice. Would that make a difference, I don’t know…

After this download, I did a complete installation as administrator, as recommended. Here is the list of installed NVIDIA applications:

NVIDIA Control Panel (default settings)
NVIDIA FrameView SDK 1.3.8513.32290073
NVIDIA GeForce Experience 3.28.0.412 (default settings)
NVIDIA PhysX System Software 9.23.1019
NVIDIA HD Audio Driver 1.4.0.1
NVIDIA Graphics Driver 555.85

Once again here, HiDPI activated or not, with 'Scaling Application or without, Cubase is functional. No more flickering from Steinberg VSTi.

This is where I no longer understand, when I encountered this VSTi flickering problem, it was the same NVIDIA applications that were installed. The only thing I don’t remember is whether I installed the Desktop or Notebook file. Could this have such an impact?

Previously, I managed to find a solution to the problem by enabling the ‘Spatial Image Scaling’ option in the GeForce Experience app settings and selecting a render otherwise it was hell. And why only Steinebrg VSTi had this problem?

I admit I understand absolutely nothing about it. Currently all these applications are installed with default parameters and it works…

I would like someone to explain…

Hi,

That’s why should be the internet disconnected, to don’t download a generic driver. The result of this might be, you don’t get the native driver, but the generic one, of the generic one is newer than the native one.

The laptop version could try to save the energy, do the redraw might be slower.

@Martin,

I didn’t mention it, but I had disabled the Internet before uninstalling the graphics card and NVIDIA applications so that Windows couldn’t connect. Despite this, he detected the card and activated it. Was this done from existing files on the C drive in folders I don’t know exist? I don’t know, but the curious thing is that the graphics card was functional and I no longer had any problems with the Cubase VSTi.

I installed NVIDIA drivers only after what I mentioned above.

Hi,

In this case, yes, it was taken from the system.

When uninstalling, there is an option to delete the driver software as well:
image
… but Windows will always need some basic VGA driver in order to display anything at all.

Hi,

That’s correct. But if the computer is online, Windows tries to find the latest universal driver. Later on, if you install the dedicated driver, it might happen, the universal driver is newer than the dedicated one. Then Windows refuses to install the older driver and you are stuck with the universal driver.

1 Like