O Cubase, Why Must You Merge My MIDI?

I am going crazy. It’s probably just me. But here’s the situation. Windows 7 64-bit fully patched drivers, legit 6.0.4, etc.

I use Band in a Box for backing tracks for guitar practice. I’ve been routing it through a LoopBe1 virtual MIDI adapter to Ableton, but Ableton’s 32-bit puniness is no match for my stack of memory-consuming VSTs. So I want to switch to 64-bit Cubase.

I add an instance of (also legit) Kontakt 4 to the VST Instrument Rack. I insert an Abbey Road Drumkit in Kontakt. I set the MIDI input on the track to LoopBe1, channel 10. I set Abbey Road to only listen to channel 10. But still, all of the MIDI events going out of BIAB are being played by the drumkit. If I set up a bass on channel 2, same thing happens, it acts like Omni is on.

The image below shows how I have it set. Is there someplace else to tell it ONLY FREAKING USE CHANNEL 10? Any guidance would be appreciated.

Blame it on BIAB’s output, not C6.


Activate ‘Input Transformer,’ the little box right below the ‘e’ editor button in the top panel of the inspector for the track you want to only receive Channel 10 (or any other specfic channel for that matter, like the BIAB default channels for their ‘band’ instruments.)

When you click on Input Transforme’ a little drop down will give you three choices: pick ‘local.’

A dialog box opens. In the preset there is a drop down menu: select midi channels> channel 10.

Notice that there are four ‘tabs’ in the window and you are on tab 1 (if you haven’t changed anything). Right on the tab label is a little hard to see circle which is the ‘on’ button for the function you have chosen. Click it and it lights up.

This track will now block everything but what comes across channel 10.


Thanks, I’ll try that, but it sounds like that means I’ll need a separate instance of Kontakt for each instrument channel, which is suboptimal.

I will also point out that the BIAB/LoopBe1 output works perfectly in both Ableton and Sonar, so I’d like to understand why it isn’t working with Cubase…

Is the BIAB transmitting multiple channels, with the kit on ch 10, and you want the other incoming channels to be played on the same instance of Kontakt? If so, try, simply, setting the channel on the MIDI track to “Any”.

The problem is that, even when the drums are set to just receive data on channel 10, they instead receive all the data on every channel. Every instrument I add, no matter what channel I set them to, receives all MIDI data from all channels. So if I add a Trillian bass, and set it to channel 2, it not only plays the bass notes being sent on channel 2, but also all MIDI notes sent on the piano and drum parts (even though they’re on channels 3 and 10 respectively).

I can leave the same BIAB song playing, close Cubase, open Ableton, and all the individual channels are going the proper instruments (same Kontakt/Trillian/Play Goliath/EWQLSO VST loadout). If I watch the raw MIDI note on/off data stream, it has the correct channels in it. It is only when I load Cubase (same song still playing) that suddenly the MIDI gets merged.

I was hoping it was just some stupid newb setting thing I was getting wrong, but I can’t figure out any place else to tell ‘ONLY LISTEN TO CHANNEL 10 FOR THE DRUMS’.

Go back to Como’s suggestion. So long as each MIDI track has its own (i.e; “local”) filtered Input Transformer, each track (set to the appropriate channel) can still access the same instance of Kontakt (I don’t know why you thought it couldn’t :confused: )

Because I hadn’t really internalized the idea that there could be a many-to-one relationship with MIDI tracks to a single VST. That makes sense, I’ll try the transformers, thanks.

Ok, clicked the Input Transformer, then chose ‘Local’. In the dropdown I picked ‘Channel Filtering Pass Channel 10’. When I close the dialog, the Input Transformer button remains orange. Now the drums aren’t getting anything.

Now the drums are making noise! (I’d muted them to listen to the drumkit play the piano part.)

Thanks for the pointers, I appreciate it. I would have discovered input transformers myself sometime around Christmas I imagine… if I was lucky.