OBS streaming using Cubase audio

how to use the audio from Cubase to stream in OBS

That all depends on your audio interface and if it has a loopback mode

For this there is Voicemeter but a bit complicated to set up
Otherwise there is a small free plugin from Reaper
which is part of a ReaPlugs suite to download
just insert the plugin in the stereo out track of Cubase and add the plugin in Obs
you have to go to audio input capture filters and select Plugin VST2
it will appear in the list after installation of course
It works very well
and it’s less of a headache than the first solution
Well, that’s only my opinion

1 Like

Voici le lien

You don’t need to do any of that if you gave an interface with loopback options. I have an RME interface which supports this.

Yeah, an audio interface with loopback makes this very easy indeed.
Which brings us back to the question: Which audio interface do you use?

Just an example if you have an audio interface with loopback ability.
This is without using Cubase’s Control Room so that it works in every version.

I create an output bus “To OBS” in Audio Connections. This gets connected to the stereo channel pair of my audio interface where I have activated loopback. In this example Adat 5 & 6.

If I only use 1 audio track I can use a Sends slot to send the signal to the “To OBS” bus. In OBS I will choose the pyhsical input from my audio interface where loopback is enabled. In this example Adat 5 & 6.

If you have several tracks you can route them all to a group track and use a Sends slot there.

If you have a version of Cubase that support “Direct Routing” you can use that instead of the Sends slot.

1 Like

I guess it also works with the Control Room
I have always had problems understanding buses and physical links
that’s why I’ve been going through realstream so far
I have a Motu 828 Mk3 Hybrid sound card.
I will test with your example.
This is why I love forums.
We send and we receive a lot of information
and tips that help you move forward
Thanks very much

In Control Room you use a Cue Send instead of a Send or Direct Out. The rest is pretty much the same.

This is the same setup that you would use to send a submix to a performing artist on their headphones. The difference lies in the settings of the driver of the audio interface. Instead of sending the signal to a physical out the driver has to re-route the signal to one of its audio devices (loopback)…
MotU have this video to explain how to setup loopback on their devices. Maybe yours is covered, too.

The advantage of not using the Reaper plugin is that with Cubase 13 that particular plugin will not work anymore. Either Cockos make a VST3 version of it AND OBS implements VST3 support (I saw somebody is working on it but hard to tell if they will succeed) or - tadaa - you use loopback.

Yes it works but without the Control Room
We’ll see when Cubase 13 is released.
where we are
But it’s true that the Reaper Plugin
seemed easier to use
Anyway thank you for your answer
After that it was not me who asked the question on the forum
No news from jerrywesti

I thought they said two years support fir vst2

And very false joy
I thought it worked but I just didn’t disable the ReaStream Plugin
I understand the principle of the return function on my Motu 828mk3 hybrid

but where I can’t manage it is in Cubase with direct routing

I redid a test under my old Cubase 11 Pro and by dint of groping it works
But the sound is much weaker than
with Reastream

Open a MixConsole and click on the marked triangle icon (there are three of them in the vicinity, make sure to get the marked one).
In the pop-up menu activate the marked option “Direct Routing: Summing Mode On”

That allows you to have more than one destination in Direct Routing active at any given time.

Yes I just set to summing mode On
it works but the sound is very distant
There is something I must be doing wrong with the FX tracks

because I manage to send my reverb tracks to Obs but not the FX track that I added because it created a loop and my ears are full of it

What I do is create a group track that acts as the Master Stereo Out. Instead of routing channels to the normal stereo out they all go to that group track. On this group track I use Direct Routing: one slot goes to Stereo Out, the other to the OBS output. This way I will always get the same level for both.

Thank you for taking the time to respond to me.
I’m going to have to do some more tests and rack my brains.
I stop with my questions