Off-beat dotted notes

Hello! Is there a notation or engraving option I’m missing here?

I’d like to have as a house-style never allow offbeat dotted notes, so the music is always like the first example, not the second. Is there a way to do that? Thanks!

There might be a special way to input the Time Signature to get your desired result, I am not sure though…

I don’t think that’s the case, since I’d like it to be regardless of time signature, be it compound, regular or irregular.

To argue against it, if something is off-beat, there has to be a beat.
If you input your time signature as 16/16, how do your dotted notes look?
If they give you the desired result, input a hidden 16/16 time signature from the second bar onwards.

Changing the signature seems like a really weird workaround for a not uncommon house style decision. It doesn’t work, anyway.

Note groupings are in Notation Options, and they cover splits across the beat, not within a beat.

I went to my computer and made an example file. This is, what I get:

So there must be something with your settings, at least that’s my guess…

Alpenhorn example.dorico (520.5 KB)

That’s the format that Piero doesn’t want!

Ah, ok that was me misunderstanding what you mean by first and second example (first note, second note??)…
Anyway, here are the Notation Options to set these things up:

Yeah I want to avoid exactly that. I messed around with every notation option I found with no luck. Maybe it’s not possible.

I think what you need to do is make sure that “Force Duration” is on (letter “o”) in Write mode before entering the notes.

I know, that’s what I did for the example. I wanted a project wide solution, but seems that there really isn’t one.