Offline Processing Not Working

I’ve come to a spot in my current project where I have to use offline processing a lot for restoration. I’m using RX effects for that, de-noise, de-reverb, de-clip.

The manual makes it clear that when you select an event in the timeline, only this event or region is being processed by offline processing.

I now selected an event and had to apply gain from the “Process” menu. It worked. It was only later that I realized it wasn’t only applied to this event only, but to the whole audio clip. And everywhere this clip was referenced by other events, the gain had been applied. How frustrating looking for all events using that clip in the project.

I then wanted to apply some de-noise to another part and when I hit preview, I would get a totally different section of that audio clip, not at all what I selected as event.

Currently, to me, it seems to be totally random. Sometimes I open a plugin for offline processing and it previews and loops the correct event of the audio clip, and sometimes it seems to just take the complete clip, no matter what I selected.

I tried directly opening a plugin from the context menu (right-click) and also opened the sample editor with the event, where the start and end were marked correctly, and opened a plugin from there. They all opened the complete clip instead of just the selected and shown event.

Anybody came across this effect, has a workaround, or thinks this has to be a bug?

Check Preferences - Editing - Audio…

There’s a setting called “On Processing Shared Clips”, make sure it’s set to “Create New Version” and not “Process Existing Clip”.

Hmmmm… this I don’t see… or hear rather. With RX DeNoise I get the event as a whole if that’s selected, or only the region in question if that’s what I’ve selected.

Got it, thanks! Yeah that was probably the problem with the “Gain” process that processed the whole clip rather than the event / region only.

But this I find contradicting in the manual. For the “Create New Version” setting the manual says:

On Processing Shared Clips
This setting determines what happens when you apply processing to a shared clip, that is a clip that is used by more than one event in the project
• Create New Version
A new editing version of the clip is automatically created, and the processing is applied to that version (leaving the original clip unaffected).

So the manual says this is specifically for clips that have more than one event in the timeline. Strange, because in the “Offline Process” section it says:

1.If you process an event or a selection range, a new audio file is created in the Edits folder, within your project folder. This new file contains the processed audio, > while the original file is unaffected> .
2. The processed section of the audio clip (the section corresponding to the event or selection range) then refers to the new, processed audio file. The other sections of the clip will still refer to the original file.
• The original, unprocessed audio file can still be used by other clips in the project, by other projects or by other applications.
• Since all edits are available as separate files, it is possible to undo any processing, at any point and in any order!
This is done in the Offline Process History dialog.

So here it says that the original file can still be used by other clips in the project. And this is what I wanted. I selected an event and wanted to process gain on this event only. Leaving all other things intact. The manual doesn’t say I should create a new version. It should not be needed!

I tried the “Create a New Version” setting and it basically processes the complete file (not only the section I selected) and just saves it as a completely new file. Which makes also the offline process history disappear because there is none. The file was duplicated. This is not what I intend and also eliminates the benefit of offline processing and the process history to me. Right?

As to the other problem. I have no idea where to look for. Here, I made a small vid. That’s how it looks like. I play a part of a longer audio recording. Then want to offline process it. But Nuendo does the preview from the beginning of the audio clip. No way I can judge from the beginning of the clip how the part I actually want to process sounds like.

Here’s a video.

Funny enough. When I open the sample editor, even with “Edit Active Audio Event Only” activated, when I select a plugin for processing, it previews and processes the complete audio clip. Not only the selected event.

BUT, when I right-click on an audio event in the timeline and open a plugin from the plugins menu directly (not going through sample editor), then it previews the correct portion and also applies processing to the correct portion of the clip.

Strange thing is I could have sworn that I did it like that yesterday (directly through the menu, not through the sample editor) and I ran into the problem. Is this inconsistent and depending on the moon phase or is this really the difference in behaviour between sample editor and process menu? This cannot be, can it?

Ignoring for a second that the manual seems unclear, my setup works as I expect it to. Creating new leaves offline history while changing only a section of the event. And playback is fine.

Interesting. Are you on PC? I’m on Mac so it’s either such a problem, or my project somehow is corrupt (I’ve had some weird issues where in one project something works, in another one it doesn’t - or until the next reboot - and I’ve also read on this forum of such ghostly effects).

I’ll leave it for now as the project is almost finished and will try it on the next, new project file to see if it still doesn’t work.

So for you it works from the right click context menu as well as the sample editor it works for you. Preview is OK ?S o from a longer clip, when your event only shows a small portion of it, the preview really only shows this one portion even if opened from the sample editor?

You’ve looked at my video I guess, right? In my project, it doesn’t work as in yours, correct?

I’m on a Mac, have watched your video, and have never experienced results such as yours ACROSS multiple plugins. I’ve had odd results in RX, but in my case they’ve either turned out to be RAM/processor (or unknown) limitations or, more typically, user error. The latter certainly does not seem to be the case for you.


Thanks Chewy. I’ll keep an eye on this if this is a one off for this project or happens all the time.

I’m on a PC, Win 7 x64.

I just looked at your video (didn’t listen, I’m at work), and if I’m in the project window and open an offline process / plugin from there it’ll preview as it’s supposed to. I typically never use the sample editor, so I’ll have to wait until I get home to check it out.