OK, perhaps an idiot here..lost MIDI control of VSTi in C11

I have a few Programs setup that were working fine/producing audio yesterday as I played my MIDI connected keyboard. I am using a SL NumaCX2 MIDI keyboard, btw. So I see that the MIDI signal is being sent to my Project via the meter to the bottom left of my Control panel - but the keys of the VSTi instruments do not move via the MIDI controller - and therefore no sound. I can play the VSTi instrument with the mouse and audio is produced in my Project, but the controller cannot seem to find the keys. And yes, the VSTi control panel shows that the instrument is turned ‘ON’.

OK, idiot mistake here? I cannot figure this out…

mr roos, I’ve had an experience like that some long time ago. For me, my “midi thru Active” preference some how became disabled.

Go to preferences > midi > midi thru active.

Once I enabled it, I was back in business. Might work for you too.

Ron

Can you see your controller in the Studio Setup and is the checkbox active for: In ‘All Midi Inputs’ ?

This is already set, so no this didn’t take care of my problem. Anything else you can think of?

Have you checked with the midi monitor what messages are being sent ?

Just throwing out ideas. Any automation? Any CCs tied to Volume, Velocity not being followed? Any expression maps in use? Record enabled or monitor on? Instrument disabled and then re-enabled? Mute and solo the track some times. What else? I can’t think of anything else.

Do you have the Midi input for your VSTi set to All Midi Inputs? Is it set to a channel that your VST is expecting?

Are you getting events into the MidiMonitor, if you use that as a Midi Insert (as per @FilterFreq)?

Additional things to check:

Are you filtering the midi channel of your controller or note events in your Preferences?


e.g. I’m filtering Channel 16 in my setup - since I use that channel for sending remote control Cubase commands.

Do you have any Global or Local Input Transformer filtering active?


This setting kills all notes coming into the track.

Nico5, Yes! That was the problem. I’m not a MIDI guy and I had gone to the MIDI-MIDI Filter section trying to understand the operation of sending key commands to my NC2X and while there I engaged channels 1-2-3. Stupid on my part because I was transmitting Upper, Lower, and bass pedals on 1-2-3 in my iK B-3X VSTi. Lesson learned and thank you, all of you.

1 Like

Glad you got things working again. And may the midi force be with you! :smiley:

p.s. Once you get into the groove with midi, it can be a quite rewarding experience. So the growing pains can come with a big pay-off.

Nico5, thanks for the encouragement. And now that I’ve solved this issue (self-created) I’ve run into something else that I hope you can help me with? I’ve watched 15 videos showing Cubase recording MIDI notes while using a VSTi channel. I can’t seem to pull this off with just the one channel. I have to create a Group and then an Audio channel and reroute things to do this. I have read and reread the manual so many times I’m just puzzled why there is not a simple explanation. Or is this a simple operation and I have again set something up within my settings to cause this to be complicated.

Is it easier if I use the Steinberg VSTi instruments? Is this true? I’m trying to use some Waves instruments, Kontakt keyboards, and the iK H-3K (VSTi all), and it just seems like I’ve got something set up wrong. I can play/hear the instrument and see the MIDI signal jump as I do, but when I hit Record, there is no MIDI info to record. Man, I’m seriously stumbling around here. I don’t get it.

Using the included Steinberg instruments just makes it a little bit easier for others here on the forum to replicate what you’re trying to do.

First, I’m not 100% sure if I understand what you’re asking.

Are you trying to create an Audio track from your midi track?

If yes, that’d very easy: That action is called “Render in Place” - and you’ll find lots of info about it in the manual and on YouTube.

Hi, Nico5. Yes, oddly enough I know about the render option and I have used it. But my problem of late is trying to record the MIDI info? My Keyboards are connected via USB MIDI and the MIDI receive signal is visible in the Project - and my VST instruments are loaded and playing their respective audio. Everything looks great, as if I’m all setup to record the MIDI information. But when I hit Record, the recording process starts, and then nothing shows up - no MIDI information is printed.

I don’t get this. Watching various videos (as I try to sort why this is not working) I see it is super easy: load the VSTi, connect the keyboard, hit Record, and it’s done. Super simple. But not here. I must have goofed something up when I was checking out all the MIDI preferences, although I think I have sorted this at this point.

So maybe I have this process, wrong? I should be able to load a VST instrument, connect the MIDI keyboard to it, hit Record, and be left with a recorded MIDI track. Correct?

I assume you already checked all of the suggestions in the beginning of this thread?

Here are my Record - Midi Preferences:

Another thing to ensure is: A channel needs to be “record enabled” to actually record anything.

If things get complicated, start with a new project - just a single track with a VST instrument.

Also, if you gotten yourself into deep customized Preferences trouble, maybe try this disabling the custom preferences temporarily (and running with default preferences): https://steinberg.help/cubase_pro/v11/en/cubase_nuendo/topics/customizing/customizing_the_preferences_disabling_t.html?hl=default%2Cpreferences

1 Like

Thank you, Nico5, I have these settings now installed on my C11. However, I’m now realizing that I don’t see any MIDI OUT signal in my Project window and this is probably the problem? I have an audio signal in my Channel strip, and ‘MIDI In Activity’, but no ‘MIDI Out Activity’. Is this something that I need to change?

You only need to see midi out, if you are driving external midi hardware.

Oh. Damn, I was hopeful! I guess I will have to trash my Prefs…

One thing that strikes me as strange, when I start the Record process, I have a 2 bar count off. As the first bar counts off, I still see that I have ‘MIDI In Activity’ signal going to my Project but the audio indicator from my Channel strip stops. How can I have MIDI activity and yet not be able to record the MIDI? This is killing me…

Just deleted Prefs and still no Joy.

Maybe start with a new project - just a single track with a single VST instrument? And then maybe upload a screen capture with your post?

Here, I hope this helps.

I’m actually playing the Roland Keyboard as I take the capture. It shows MIDI Activity In.

But it looks like Cubase is currently in stopped mode. You’d have to be running by pressing the Record button on the Transport controls to record Midi. – Cubase works a little like a tape machine that way.