Olympus Choir Micro issues


I have installed the choir on one machine running Elements the other SE along with Halion SE 3 using the Steinberg Download assistant.
Both machines run OSX.

I did the following on both machines:

  • created an empty project
  • added a soprano
  • added Halion VST in Elements; Halion VST was autoloaded along with the soprano
  • bring up Halion UI:
  • Elements has the legatos and can show the choir UI but the midi keyboard is not working
  • SE does not show any legatos and hence the choir UI cannot be brought up

I have attached the diagnostics file for both machines.


Thank you,


PS It is also confusing that the Halion SE UI has “Halion SONIC SE3” in the upper right hand corner, yet when editing, say “Ash Choir & Strings” I see “Halion Sonic SE2 Hybrid Expansion”.
Dorico Diagnostics.zip (345 KB)
Dorico Diagnostics.zip (480 KB)

You can’t use the Olympus Choir Micro library with only a Dorico SE license. It’s not included with Dorico SE and won’t work without at least a Dorico Elements license.

Thank you Daniel!
How about the 2nd problem? Namely that the midi keyboard is not working.


Sorry, I missed that: I thought you meant that the keyboard in the HSSE window wasn’t working, which I would expect if the sounds cannot be loaded and used.

Does your MIDI keyboard appear in the MIDI Input Devices dialog (in the Play page of Preferences) and is it enabled there?

I think I have a pilot error …

My impression was that I can sample sounds using the midi keyboard before entering any notes in the score for any of the loaded VSTs.

It appears that the product use model allows me to do that only after I have entered a note; in other words I can hear the note as I enter it and/or I can use a VST’s player from within Dorico.

I thought that I can hear a VST’s sounds before entering any notes.
Therefore it turns out that Olympus Micro behaves the same as any other VSTs I have; I just didn’t expect that use model.

Thank you just the same!


Dear Alex,
You should indeed hear the sound of the player you want before entering any notes. In play mode, make sure that the player is “highlighted” – there is a tiny vertical coloured line that appears to the left side of the player’s settings. That’s how you tell Dorico that this is what you want to hear, even if note entry is not enabled.

Indeed, Marc! Thank you!