one midi track to control several VST Instruments (and more than just 4 via midi sends)

Not much on the web about getting more than 4 midi sends going from one midi track, so in case anyone is looking for how to set up one midi track that controls as many VST instrument tracks as you want, here is a workaround I found. The catch is that you need to own Reason and use the reason rack to do my method. Im pretty sure there are other VSTis out there that can do the same thing so this can likely be done with other VSTi’s that feature Midi out and midi thru. I’d guess that Kontakt must be able to do this too, but Im not sure how to set it up in Kontakt. Heck, there might even be a built in VSTi in Cubase that you can do this with (im new to Cubase so I dont know this Halion and groove agent stuff at all yet). Anyway, here is how I do it with Reason Rack:

Step 1: Create an instrument track with Reason Rack. Load a “Midi Out Device” in the reason Rack. That’s all you need to to do with reason rack. By doing this, you have essentially turned this instrument track into a midi track wih a super power: it shows up in other instrument tracks as a midi input!

Step 2: So now, create an instrument track with whatever VSTi you want. In the Inspector window on the left, set the input of this newly created instrument track to be the reason rack track’s “Event Out”. Also make sure to enable the track monitor, which is that little speaker thing you can turn on an off. It’s in the same area as the track name.

Repeat Step 2 as many times as you’d like.

haha cubase is such a weird DAW.

Does anyone have a workaround better than this? Maybe something that is built in already and doesn’t require a third party vsti?


If you route 4 MIDI Sends to a MIDI Track and enable 4 MIDI Sends on all 4 MIDI Tracks and route them to other 4 MIDI Tracks, you can get up to 16 MIDI Send Destinations. And of course, you can continue with the cascading endlessly: 256, 65.536…

Hi Martin -

Nice thanks for the suggestion! Just tried it out in a project, I think I might be missing something. Maybe I need to check a box somewhere or something?

I made an empty session, created two midi tracks and one halion instrument track. The idea would be to record some midi on midi track 1, then send the midi from midi track 1 into midi track 2, then send the midi from midi track 2 into the Halion instrument track.

So I recorded some midi on the first midi track. Then I went to the midi send section on Midi track 1, enabled the first send, clicked on “not connected”, and looked to try and choose midi track 2 as the destination for the send.

However, I do not see midi track 2 as an available destination.

So I must have either misunderstood your suggestion or maybe there is some box somewhere that I need to check that would allow me select a midi track as the destination for a send on another midi track?

Thanks again!

Assuming you’re on a Mac, just send the output of the midi track to an IAC driver bus. Set the input for as many instrument tracks as you want to that IAC driver bus. If you don’t already have the bus, use the Audio/MIDI app to create it. Turn on monitoring for the instrument tracks to hear the output. If you’re on Windows, I don’t think there’s anything built in to the OS like IAC on the Mac, but you can use something free like LoopMIDI.


I’m sorry, my theory was wrong.

Nice thanks Glenn. Haha the IAC bus indeed has been staring me right in the face the whole time. a while back I had messed around with the IAC bus to sync up two DAWs (I dont believe either of them was Cubase). I barely remember it but all I remember was that the experience was buggy and had latency/jitter issues. So I’ve always tried to avoid using the IAC bus since then

That being said, I never really tried to troubleshoot or anything, so who know what the actual problem was, I dont even Cleary remember exactly what I was trying to accomplish at the time. So I’ll go ahead and try it out, if its stable and no jitter problems, then I think this really would be the best solution.

Thanks Glenn!