“One or more components for Dorico Playback have not been found.” SOLVED


I use Dorico 2.2
I just installed Dorico 2.2 a few days ago on my new PC and reactivated the license. The previous Soft-eLicense was on my laptop.
I installed “Dorico Playback 2 - Orchestra Library” as well as “Dorico 2.1 Playback 1 - HALIon Sonic SE 3”
I also tried reinstalling the last 2 sound library several times (Dorico Playback 2 and 1).
I restarted my computer, but I still get the notification error when I launch Dorico:
If I skip the error and enter Dorico, all the sounds would play as sinewaves. Funnily enough even the dynamics and tempo are played according to the sheet music, but there’s just no sound libraries playing.

I tried to look up solutions from the forum and from one thread I realized I don’t have HALion Library Manager and couldn’t find a place to download it. If I understood correctly what managed the sound libraries in the older versions of Dorico is now replaced by Steinberg Library Manager. In any case I downloaded Steinberg Library Manager but nothing shows up there even after reinstalling all the libraries and restarting the computer. All it shows is “no libraries found”. Surely there’s a way to reactivate older versions of Dorico on a new device and have playback working normally. What can I do?

Highly appreciate your time in helping.

Also here’s a piano project with a few notes.
Playback issue.dorico (312.5 KB)

And a Diagnostic Report
Dorico Diagnostics.zip (719.0 KB)

Did you install from Steinberg Download Assistant Josef?

Yes, that’s where I downloaded all Dorico’s stuff from. Here’s a screenshot of it.

Thank you Josef!
Well, first I opened the project with D3.5 and I didn’t find any instrument loaded in HSse. I added a piano and it played back perfectly. I’m adding the saved project:
Playback issue 3.5.dorico (464.3 KB)

Then I found somewhere D2.2 and opened your project (btw nice sensation! I didn’t remember the look and feel of D2.2!): same situation no instrument! I added the piano, but it didn’t sound! Then I changed the asio driver with the last distributed and everything was perfect!
This is the 2.2 version
Playback issue 2.2.dorico (409.4 KB)
This the MIDI
Playback issue - Full score - Flow 1.mid (161 Bytes)
and this the audio

Hi Alberto, first of all thanks for the fast replies! But I’m not sure I follow what exactly you did to solve the problem. Could you elaborate on what you mean by changing the asio driver with the last distributed?

Josef I choose the last ASIO driver instead of the Generic one. But I don’t know if the last is distributed with D2.2 in SDA. Anyway, the real issue was that you didn’t have an instrument loaded. What happens if you open my files: 3.5 and 2.2?

For the ASIO driver, can you open the Device setup and control the Device control panel? is the sample rate OK?
I think that also the Generic ASIO should work for you, so forget my change…

I could open both your files, but there was no sound. But when you mentioned the instrument not being loaded, I checked the VST instruments from the Play menu, and could see other VST instruments available but no HALion Symphonic Orchestra which probably should be the one I installed. So the playback works with for example DoricoBeep.

Sorry here’s a screenshot of the list under VST instruments in Play mode.

So it looks like you don’t have HALSse installed…

For my device setup I’m using Focusrite USB ASIO which should be my focusrite scarlett 2i2

OK Josef, as I said the problem isn’t the ASIO driver, the issue is HSse. Can you open it standalone?

Ok I cannot understand how stupid I was. I downloaded the installers but did not actually install the files… Problem solved. Thanks a lot Alberto!

1 Like

:+1: :bangbang: (check the thread as solved…)

I couldn’t find the place to check it, still need your help for that :smiley:

1 Like

You found it! :smiley:

Oh okay so selecting a reply as a solution does it. Thanks!

OH! I missed to welcome you to the forum…!
So, Welcome Josef!

Thank you! And thanks again for the immediate help!

1 Like