Only first page is printed


Last time I exported part to pdf only the first page of each layout was exported. The “All pages” button was already highlighted. On closer examination, the “From - To” box said 1 to 1. I went to write mode to view the parts, when I went back to printing everything worked as normal.

Did any of you experience the same?

I swear that I never touched the from-to setting.


It happened again. Score and four parts printed to pdf, one of the parts was printed with first page only. Is this just me?

Can you send us a screen shot of the right side of Print screen? (Or too late)? Are you using only Dorico’s print areas, or do you get to Windows printing dialogs? Anything look amiss?

Sorry, too late…
I was using only Dorico’s print areas, all the settings seemed right.
When only one layout is selected, the from-to fields will show 1 - 15 (for instance) even if “all” is selected. When more layouts are selected the from-to fields will show 1 - -. I think that when this happened, there was a number also in the second field, with more than one layout selected. Maybe that has to do with it.

This also happens to me. It is very irritating, because there is no pattern. Sometimes there is only one of the parts affected, often more than one.
I did a piece this morning. The print settings are attached. The ‘All Pages’ box is selected. On the layouts panel, all the layouts are selected (Score and all parts).
The resulting list of pdf’s are shown in the ‘pdf files’ attachment. The files which are 26KB have only the first page. The others are created properly. The only way I can correct this is to do it again and again and again until all the pdf’s are created correctly.
print settings.PNG
pdf files.PNG

Sorry to hear that, but good to know that I am not hallucinating.
I haven’t either been able to see any pattern. I will try to use an external PDF printer and see if that is more reliable or if the same thing happens with that.

Do make sure, by selecting each layout in turn using the list on the left-hand side of the window in Print mode, that each of your layouts is correctly set to ‘All Pages’, before you select them all and choose Export.

Thanks for that, I will try it out for the next piece I do. Interesting though, that yesterday the first pdf creation was poor, (as you saw). I made no changes, I simply pressed Export again, and the second was better. I made no changes and the third corrected all but one of the layouts.
That seems a bit odd.
I really want to move over to Dorico, but I’m finding that all the time saved by some of the truly wonderful features of Dorico is swallowed up (and more) by the difficulties of accurately laying out staves, this pdf creation glitch (I’m now going to have to check every single layout before I create the pdf) and then renaming every single pdf, because they come out in alphabetical order, the difficulties of lacking drum kit notation…

What problems are you having accurately laying out staves? Dorico does a pretty good job of that on its own, and you shouldn’t need to intervene too often. It suggests to me that you might be missing some of the options that we have provided to allow you to influence what the program does.

I appreciate that Dorico isn’t perfect, but I hope you can see that we have a strong commitment to making it better. We can’t fix bugs we can’t reproduce, but if we can pin down what is causing the problem with PDF export, of course fixing it will be a high priority for us.

Daniel, I really like Dorico, and as I said in my reply, there are so many wonderful features of Dorico, and I really want to move completely, but like so many others on the forum, there are features that I really need in order to tip the balance in favour of Dorico.
I tried to start a discussion about laying out staves in threads: (Scaling Staff Spacing) and (Staff Spacing Question), but there were no takers, and no-one to suggest some of the options I may have missed.
Dorico is the future, and you and your team have a fantastic commitment to the project. I am totally committed to moving, and I know that all these glitches will be ironed out in time.

Regarding staff spacing, you should find that Alt+J/K or Alt+dragging works from the bottom of the page upwards just as it does from the top of the page downwards. If you work from the bottom of the page upwards, you can use the handle of each successive system and Alt+drag it upwards, and the positions of all systems below that one will remain fixed.

It is true that, if you manually position the top and bottom system on the page, and then want to evenly distribute all the systems between them (which I guess you would do usually only for parts), that’s quite laborious at the moment, but our approach was that you should be able to position those staves using the values defined on the Page Setup page of Layout Options for the top and bottom margin of a frame (which settings are also overridable in the Properties panel for an individual selected frame), which will then produce an equal spacing between the systems, unless there is a good reason to deviate from it. Perhaps the ingredient you are missing is that you can specify the position of the top and bottom staves on the page using these options?