Opinions on Direct Offine Processing

Nuendo 8.1.10 was released a few days ago with a ton of DOP fixes, and Izotope recently released updates for their plugins that improve Nuendo 8 support.

I’m curious to hear how well DOP is working for everyone now. Did anyone run into issues while using the current version? Are there any changes you would like to see implemented?

You are a brave man!

Hi !
This is what dop deserves, in my opinion :

  • Better integration of isotope connect !
    Find a solution to avoid having to consolidate several consecutive clips before sending them in connect. (even better: allow to send a clip in connect with handles !! I’m sure you can do it!)
    Find a solution that works for the “learn” function of denoising without having to go through izotope connect.

Thank you, and Best regards !

Here are some of the issues that I still have in the newest version:

  • Sometimes with Auto-Apply on I noticed that my latest Parameter changes are not rendered into the File, if I close the DOP window directly after I did the change.
  • With iZotope RX Connect it is still required to use the Bypass “Workaround” when DOP is set to “Auto Apply” (for me the whole RX Connect feels like a Workaround, in Reaper or Ableton Live you can just set RX as External Editor and have it open and update the projects wave files directly, would love to see this in Nuendo)
  • Previewing Sounds in the DOP window does not take their Clip Gain settings into account
  • Personally I’d like to be able to have a seperate Keycommand for the “Preview” of the DOP. Currently, it takes over the Spacebar Play command when the DOP window is in focus.
  • Changing Parameters with Auto Apply on it takes still too long until the processing starts. Normally use the DOP now with Auto Apply off and hit Apply after I change the VST parameters.

Hi,

my biggest issues (didn’t have it in any Nuendo-Version before):

  • I render a PlugIn to multiple audio clips (e.g. steinberg EQ / Waves EQ / probably any other PlugIn). Auto-Apply OFF. Then (or later) I render the same PlugIn with a different setting again to these multiple audio clips (or a random selection of them) --> Result: DOP did not apply my new settings. It overwrites the new setting with the setting of the PlugIn used before (which was the same PlugIn).
    This is a dangerous bug. Never had this problem in earlier Versions of Nuendo.
    In the left-sided DOP-list there exist only one PlugIn/process, instead of two.

BUT: when I do this “workflow” with an single audio clip --> everything works how it should. The new setting of the same PlugIn applies exactly. And on the left side two processes are listed. The problem occures only with two or more audio clips.

  • unfortantely the settings of WAVES PlugIns are deleted when you reopen the DOP-window. Please fix this bug.

Thank you,
best regards, Alex

I like to work with “Auto Apply” turned on as I do dialog work and lot of declicking needed. It really speed things up to be able to have the PlugIn working while I go on editing. What I had to get used to: It can happen that I play a clip and still hear the click, next time I play it the click is gone (without me having done anything in between.) But knowing that work is very fast.

Now when I use “Connect” first step is great: after hitting the KeyCommand for “Connect” DOP opens and Izotop loads the clip automatically in the RX editor. But now after sending the treated clip back to “Connect” DOP I need 3 clicks to make it play on my Nuendo track: click “auto apply” off - click “apply”- click “auto apply” on again (to be ready for me next series of deklicking.)
Strange is: In 8.1.00 I did need only 2 clicks: “auto apply” off - “auto apply” on would make the process play on the track.

Oswald

Hi, just started to mess with the DOP and RX 6, my problem is why does Nuendo uses only one core of a multi-core CPU for rendering the file ?

It’s taking me more than 10 minutes to De-Crackle a 35 min audio file in high quality mode because of the 8 core of my machine, only one is running at 100% during the rendering process…the 7 other cores are not used, they just sit idle…I’m pretty sure that when I do that directly in Rx 6 Stand-alone it uses all 8 Cores of my cpu and goes 8 times faster to render the new file…

Any hints on this ?

Regards
Yannick

Multiselection (17 Audio tracks) -> UAD2 Studer A800

Completing Direct Offline Processing window -> C’an’t Abort !

Estimated Time Remaining -> 36min…and keeps going up

Windows task manager says 2 to 4% of the processor is used…

I have to kill the Nuendo app…;PITA

Isn’t that normal, since all the processing happens on the UAD-card?

Fredo

Hi Fredo, you’re right, it’s only when ASIO buffer is very low that the CPU gets hit by UAD cards.

Nevertheless what’s with the “Completing Direct Offline Processing” window ?
Sometimes it shows up and sometimes it doesn’t and am i the only one that can’t abort ?

Sorry Steinberg … DOP is still a mess! ( Nuendo 8.1.1 )

1: Take piece of audio with handles ( that’s every single five of audio I edit ). Apply a DOP plug in effect which produces a tail ( reverb, echo, etc ). Firstly the DOP preview doesn’t even play same audio that was in the timeline ! Usually it adds some of the sound at the end in the handle. The Tails setting does … what? In the DOP preview it now seems set how much more of the material in the handles gets played. That make NO sense. “Tails” is surely how long the effect renders after the clip stops??? Anyway, return to the project and the effect tails cuts off as soon as the audio event finishes. Useless.

2: If I select the audio event and "Bounce Selection ( i.e. lose the handles … not a great idea ) then things better. The tails setting adds effect tails However the tail length is limited to 10 secs! So any extreme tails are impossible… and they do occur! So the Bounce down is a stupid step which destroys the integrity of the clip, and the tails length doesn’t take into account the range of effect setting possibilities ( even Roomworks SE has a 20 sec reverb time! )

so mainly unusable.

Very frustrating.

For the Tail setting to work, you have to set the tail length before adding an effect that’s supposed to extend the audio event, such as reverb or delay. No bouncing needed. If you forgot to do that, you can just remove the effect, increase the tail length and then apply the effect again.

That’s definitely not very intuitive though, and hopefully will be changed in a future update. I think it would also be nice if there was some sort of optional automatic tail length detection.

Note that the maximum tail length has always been 10 seconds/10000ms. This isn’t new to DOP.

Thanks for the reply

But I am still dumbfounded/confused by the fact that Tails don’t work at all in any useful sense for audio with handles … in an app designed for post production! Even after a full year since the feature was released.

Obviously I’ve contacted SB support ( US ) and they confirmed and recognized the issue and said they’d report it. I’ve posted several times about it here. Developers can’t be blind to the fact,

Maybe everyone at SB HQ are running around with VR Goggles on all excited about that … meantime where I sit there’s lots of crappy audio to edit that would take a lot less of my life if a feature in the app actually worked properly!

Rant … sorry. But seriously…

But isn’t this nothing new? Nuendo 7 processing preview was already like this.

Do you have an outline of the way you would like tails to work for audio in relation to handles? What are your precise expectations?

But I do agree with you. In general, working with tails in DOP only works with any reasonable sense if you first bounce the event. Tails on events which reference only a short section of an audio file give extremely confusing results.

Do you have an outline of the way you would like tails to work for audio in relation to handles? What are your precise expectations?

My expectations are fairly intuitive I think… " what I see is what I hear… )

There’s a piece of audio in my Timeline… an “Event”. I select it. I open it in the DOP. When I hit play the DOP plays the audio in the timeline ( not any handles ). If I activate loop … it loops the audio in the timeline. When I apply an effect, it is applied it to the audio in the timeline and I hear the preview. If the effect incorporates a Tail of any kind ( delay, echo, reverb, stretch … ) I hear the tail in the preview. When I close the DOP pane, Nuendo renders a new version of the Audio in the timeline with the tail applied. In the Timeline my audio Event is now longer by the amount of the decaying effect tail. However it still has Event boundaries so the handles are potentially available.

If I move the Event boundaries to expose more or less audio it would be nice for Nuendo to just re-render a new, longer/shorter event with audio as it is revealed in the timeline, with all the effects as applied in the original DOP pass including an appropriate tail.

If this " Adjust Handles " behavior is too complicated ( and it isn’t ) I could live with a Nuendo message saying “You’ve adjusted Event Handles” and a button to return me to the DOP pane. But I have no idea why that would be necessary.

Is there any other sensible scenario for how this should work? I’m not being snarky … I just don’t see another way that makes sense in a Post Production environment.