Opposing voices, unison note overlaps

Viola part, divisi, double stopped, so 4 notes in all, all quavers (1/8th notes). Lower voice has C and F# above; upper voice has the same F# and A above. At the moment, the two F# overlap and I don’t want them to, as it’s not at all clear that both voices have the F#. There’s surely a way to move them apart, but I just cannot find it. In Notation options, I’ve got ‘Do not allow noteheads to overlap’, but this only refers to dotted notes and notes of different lengths; in my case, they’re all quavers.
I’ve tried the various Voice Column offset things in Engrave in case that was relevant, but nothing happens.
Help appreciated!

The simplest way to achieve this is to set voice column index to ‘1’ for either the up-stem or the down-stem voice notes. The reason probably the voice column offset doesn’t work for you is because if you click on the F# notehead in engrave mode both F# in the two voices will be selected, so both voice will be offset. So it’s best to select either the C or A notehead and change the voice column index, depending which voice you want to move to the right.

…or another good rule of thumb is to click on the stem (especially if it’s a single note).

If I select the quaver tail and/or the stem (and I found it exceptionally difficult to do either), the Voice column options don’t appear.
If I select the lower note of the lower voice (which is not duplicated), select Voice Column Index, and set it to 1, nothing moves and the highlighting goes. One time of trying, I did manage to get it to move; I don’t know why it sometimes moves and sometimes doesn’t. For that, I’d set it to 2; too much; tried to re-set it to 1; nothing happened (no change).
(I tried select Voice Column spacing Offset and set that to 2, nothing happens - the highlighted note ceases being highlighted and nothing’s moved.
If I select Voice Column X offset, and set that to 2, all notes move, not just the lower voice.)
If I try to move up and down through the chord, the F# is treated as one note - if I delete it, it disappears in both voices. So what I did was delete that note, so I’m left with one note in each voice, use Voice Column Index to move the bottom note - the figure I put in the box is irrelevant, as it moves the same amount no matter what - then put the other notes back in. But the offset is far too great, unusably great, and I can’t alter that.
Surely the Voice Column Index figure should matter? I should be able to say how much I want to shift it by?
Well, whaddya know. If I change the Voice Column index for the upper voice, it moves just as I want. So that’s what I’ve done. Fortunately it doesn’t matter whether voice 1 is to the left or right of Voice 2.
But it looks as if Voice Column Index doesn’t work properly on the lower voice - it moves a set amount and there’s nothing I can do about it. Is that a bug or a feature?
(For the giggles, having set the VCI for Voice 1 to 1, I tried setting Voice 2 column index to 1 as well - the two then overlapped. I set Voice 2 VCI to 2, it moved a lot, and voice 1 went back to the position it would have, had its VCI been 0. I set Voice 2’s VCI to 3; same result as if it was 2.)

Voice column index is a relative thing, not an absolute value. What I mean is that if all notes at a position share the same index, they will be at the exact same place. It does not matter that the index value is 0 or 10. But if you have different index values, then the “horizontal order” for that specific beat will be determined. So if what you need is opposing voices with unison notes that overlap, make sure all these notes share the same voice column index. It’s as simple as that.

But I don’t want notes that overlap. Where two voices have two notes each and one of those notes is the same across both voices, then if they overlap it’s extremely difficult for a player to see whether or not they should be playing that note. What I couldn’t get was for the notes not to overlap. And the VCI behaves differently for the upper voice than for the lower, and I can’t see the logic behind that. The VCI should surely allow me to vary the gap between voices, relatively speaking; but for voice 2, the gap appears to be the same no matter what the value, and it’s an absurdly large gap too.

Dear piano888,
I find this thread extremely hard to read, because it’s related to graphic problems. Could you please post a picture showing the problem and maybe another picture showing what you’re aiming at? Or a minimal example file, with which we can play?

Here you are. I would love to have attached a proper file but the zip was only a fraction smaller than the actual dorico file (over 5MB) and wouldn’t therefore attach. So here’s a pdf.
Bar 1 shows what I had when I first posted my query.
I do not want the two voices to overlap; it’s impossible to tell quickly who of the divisi violas is meant to be playing the F# (and that it’s in fact both). So I deleted the F#, set Voice Control Index = 1 on voice 2 and the result is bar 2. Try changing the index to any number - I can’t get it to make any difference to the positioning of the Voice 2 notes. Surely that’s not right; I can’t understand the logic if it is.
Then I set VCI on Voice 1 to 1 instead, left VCI on voice 2 at 0 and that result is bar 3. I can run with that, as fortunately I don’t mind which way round the two voices appear.
So my problem is solved but I’m left thinking Voice Control Index on voice 2 is inconsistent with how it works on voice 1.
Overlapping notes extract (2).zip (21.5 KB)

Thanks for the picture, it does help.
I recreate it, so I can follow your steps. When you put VCI=1 on downstem voice 1, in that second bar, that second voice is then moved to the right, because upstem voice 1 has a VCI value of 0 (turn the override slider on and you’ll see it). VCL notes with a lower value are always to the left of higher indexed notes. You did the opposite on bar 3, so the result is the expected one. I cannot understand why you think this is inconsistent… Nevertheless, there’s a faster solution if you’re not satisfied with the order in which the voices appear : select the cluster of notes and voices (marquee select), right-click to use the context menu, and Voices > Swap voices order does the trick (in Write or Engrave mode)
Hope it helps !

If you don’t want unison notes to be allowed to overlap at all, various options for this are found on the Voices page of Notation Options, but we don’t provide an option to prevent two notes in opposing voices of the same note value from being superimposed, since that’s pretty standard practice almost without exception. The tools provided to override voice column index and, as Marc rightly says, to swap the order of voices provide you with plenty of tools to quickly and easily achieve any result you want.

What I still do not understand is why in bar 2, the lower voice is SO MUCH more to the right than the upper voice is in bar 3, even though the offset value is the same. That’s what I find inconsistent. I realise the idea of the offset is indeed to move the notes to the right - but that much? It makes it look more like a 7/8 bar. And in fact there appears to be no way to vary the degree of offset - changing the value makes no difference. Why not?
And to fix it at all, I had to delete the common F#, shift the voice, then re-enter the F#; couldn’t do it otherwise.
Overlap for notes of identical value might be standard practice but you can see why it’s unacceptable here. The viola players would tell me in pretty short order what they thought. :slight_smile:

As long as you’ve changed the voice column index for each voice, you can then turn on the note spacing adjustment mode in engrave mode and shift either column to your heart’s content.

If you have a number of these in the score, select the stem of each one together before shifting the voice column index value; it will speed things up a touch.

Thanks - that’s useful. :slight_smile:

(Can’t help thinking though: there are a great many things that Dorico does better than Sibelius; but this isn’t one of them.)

You’ve obviously changed some default value somewhere (under Voices in the Notes page of Engraving Options) because the large offset you show in the second bar in your PDF is certainly not what Dorico does by default if you offset the down-stem voice into the next voice column. This is what it looks like by default:

Yep, this is what happens when you’re trying to do something, know a little, but not quite enough to know how little you know… :slight_smile: And also what happens when you look up ‘voice column spacing offset’ in the help file and can’t find it! (I do look forward to when you’re able to get the manual writing up to date - I know it’s in the pipeline, and understand the difficulty.)

A few days late to the party, but for my own information - did you only search “voice column spacing offset” or did you search alternative versions of that? Because if you start typing “voice column” into the online help search field, one of the top suggestions is this topic: https://steinberg.help/dorico/v1/en/dorico/topics/notation_reference/notation_reference_voices_voice_column_index_r.html

If you searched for other alternatives and couldn’t find them, I’d be interested to know, as I can add some keywords to this and related topics to make them easier to find.

I only searched ‘voice column spacing offset’, as that was all that I was interested in. There are a few things where I see it and wonder what it is, and would welcome the direct means of finding out.
Thanks! :slight_smile:

That’s good to know, thanks. I’ve added the phrase “voice column spacing offset” to that topic for the next update, and it will also come up in the PDF index under “offsets” and “spacing” in addition to its previous entries.

Resurrecting this thread to request at least an option for this use case:

…which carries on for pages and pages. I would love to have a setting to turn off all superimposed unisons. I grant it’s not that common, but it does exist.

It should be reasonably quick to filter all the notes in the down-stem voice and then set the voice column index property, no?