optimize for best performance

I recently upgraded to Cubase 7 and HALion 4.5.4 and have noticed some audio dropouts when using multiple HALion patches… Is there a page with the best setting for optimal performance in the HALion sampler? Specifically I wondering what settings I should have in the Performance and Streaming tabs of the Options module. I’m using a Dell T5400, Xeon X5450 3 GHZ with 4 Gb of RAM using Windows 7.

I would have thought the most important thing here would be to get some additional RAM installed.
4GB is barely adequate (if running in 64-bit, of course) with the OS, the DAW and a RAM intensive item like HALion…
I would recommend upping this to at least 16GB myself…32GB if it can be done.
You will notice a huge improvement immediately.

Also, what is your system setup please?
I run a C drive for OS/Applications, a D drive for audio files, a drive for drum samples & another for general samples.

Other places to optimize are the number of voices running & the amount of pre-loaded samples into RAM against streamed off the HDD.

I agree more RAM would be good… I run a college lab and purchasing more RAM would be costly as we have 30 computers… my problem is the Sampler worked fine with Cubase 6. I’ve upgraded to Cubase 7.0.4 and HALion 4.5.4 and now I can’t even run the sampler with 2 patches before I get audio drop outs. This is not good.

I’ve changed the HAlion sampler settings in the options module and they have all produced audio dropouts… I’ve tried: multi-core on and off, more preload and less preload… more streaming from the disk and more streaming from ram… osc eco mode on and off… no luck.

My setup is: all apps live on the C drive and it’s locked with Deep Freeze. Students work from and save to the D drive.

halion samples should be on a separate drive for optimum usage otherwise issues like you are describing can be caused

Hi there,

this depends on the type of presets.
Synth or Samples?

You have got different solutions in order to optimize your HALion 4:

Activate the Multicore feature in the Options

Activate Osc ECO Mode in the Options

(for Sample Presets and only fully 64-Bit Environment)
Move the balance slider in the direction of RAM

(for Sample Presets and only fully 64-Bit Environment)
Try to raise the Max Preload amount



Thanks Marcus for the setup tips… that definitely helped. I put the Max Preload to the Max at 4093… and changed them all to your suggestions… I also put the Multi Loading to ‘clear before.’ It’s odd… I still get a couple less annoying audio dropouts with your suggestions… not as bad as before… I think the combination of upgrading Cubase and the Sampler has contributed to this issue.

Hm…seems to be something strange…
Maybe you can PM me your PC hardware and used ASIO- Buffer size/Driver etc.?
I think I need a bit more information.



Hello Marcus,

Here’s my specs:
Dell T5400
Intel Xeon X5450 @ 3.0 GHz
64 bit

MBox 3
Driver: Avid MBox ASIO (64bit)
buffer size 512

Cubase 7.0.5 (64 bit)
HALion 4.5.4

Your suggested settings did help - I still get some real-time peaks… I’m looking into to purchasing more RAM for at least one of our computers and see if that stops the real-time peaks.

Hi dMichael,

I recommend to do the following first:

  • Please download and use the ASIO4all Driver:


We know about a lot of issues concerning the AVID ASIO drivers because of their defective structure.

  • So in Cubase please choose the ASIO4-All driver (Device/Device Setup/VST Audiosystem)

  • Please raise the Buffer Size to the max for the ASIO4all- driver

I could bet, that this will help a bit…