Optimizing Windows 10 Machines for Cubase

Audio dropouts!

I’m sick to death with them. I’ve researched, driver updated, tested, tried solutions on forums until I’m frickin’ dizzy. I’m not on my own.

So, in the perhaps foolish hope that someone from Steinberg is taking any notice of this issue of audio dropouts, are there any potential solutions to this issue?

Yamaha USB driver 1.9.10
UR242 firmware 1.0.1
Windows 10 Version 1709 Build 16299.192

LatencyMon points to usbport.sys and storport.sys as issues. I’ve tried everything I can think of with these.

Thanks for reading. Suggestions very welcome.

Is your usb controller using the generic Microsoft drivers or AMD drivers ?
I had some issues with win10 installing the generic MS ones, they where working but with a high DPC.
After installing the intel (i7 motherboard) drivers, my DPC got really low.
Worth a try looking for any generic drivers that could be replaced.

Update UR driver and test again

https://www.steinberg.net/forums/viewtopic.php?p=702352#p702352

and if that doesn’t help list what settings changes you have tried and screencap the latencymon driver tab (highest execution at top of course).

I’d recommend getting a separate PCIe USB interface card just for the audio interface so it has it’s own bus if you don’t already have one. They aren’t expensive.

windows 10 is 2hit for audio. Go back to Win 7 and save yourself some grey hairs.

Your system may not be up to the task. My wife has an almost identical Phenom/8gb system and can’t smoothly play some VSTs that handle easily on my ancient, gen 1 i7-960 with 24gb. On the AMD system Reaper has some slight advantage, though not by much.

I had some dropout problems when I started up with Cubase. The main problem was with a few Omnisphere patches that were EXCEEDINGLY processor intensive. For instance “Light as Air” could go to 100% cpu usage when playing more than 2 notes. Simply not using that patch solved almost every dropout issue, but I still had trouble whenever network traffic got really high, such as when (for example) Adobe Creative Cloud was doing “background” updates. That was solved by reducing the cores available to Cubase to 6, and letting Windows10 have the remaining 2 cores which it now uses heavily at certain times without seeming to cut in on the Cubase cores. Task Manager was very good at spotting the network issue, since it interferes with the overall system much less than some of the other system monitors. In Task Manager I could hear a glitch almost every time Creative Cloud bounced up to the top of the “Processes” column!

I am running a huge sampled orchestra setup with at most a minor hiccup every hour or so. To be fair, straight samples are low overhead. I was looking at Massive the other day and I’m pretty sure I’d glitch out pretty quickly with that thing. I’m using a Scarlett Solo at 44.1khz, 256 buffer.

+1 for Jaadoo. I’m running Win 7 64 bit.
Now first thing when i switch the computer and start Cubase the first run of a song maybe glitchy but,
after that everything is fine so i’ve left it alone.
I’m just about to look at the manual for 64 or 32 bit processing.
I’ve switch ASIOguard off as my M-Adio 2496 card runs at 6ms latency.

After system reinstall I had crazy dropouts, nothing helped.
But then I remembered to turn Power Management to High Performance
and dropouts are gone.
Quite obvious thing to do but, check it out just in case.

__Some folk/machines have found issues with Windows 10 whereas others (including me) have found it a better OS. I assume if you upgraded from Windows 7 you’ll have noticed problems when you did so and thus will know if this is your issue?

The other suggestions above do look worth following up but as already mentioned it would be useful to know what buffer settings you’re running at and exactly what LatencyMon results you got.

I don’t see any audio drop-outs on any of my systems with various interfaces BUT have adjusted buffers and optimised everything else on my older systems to get to this state (as I might expect).

Win10 is not an issue if drivers are up to date, and you are running high performance power settings. The forced updates can be an issue, but there are ways around that if need be.

First of all, many thanks for these great replies. My faith is restored.

As I write this and following points raised in your replies, it seems I may have cured the issue, at least for now. Here’s what I’ve done:

  • Installed Yamaha Steinberg USB driver 1.10
    Installed AMD PCI to USB Open Host Controller drivers to replace the Enhanced PCI to USB drivers (Thanks peakae)
    Put all hard drives back to IDE in BIOS
    Power is at High Performance
    Latest NVidia driver (388.71)
    32 Bit Processing, ASIO guard on Normal
    Buffer is at 512
    Here’s the LatencyMon result https://drive.google.com/open?id=16fIzD3fJsdCLFTAaoY8vIOAnkHHXRoes

This represents the biggest performance increase I’ve had for ages. I wouldn’t like to say which one of the above points is the ‘golden bullet’ for me, except that changing the PCI to USB drivers is the one move I’d not tried before.

Again thanks to all. Of course, I’ll report back here if issues arise again.

I would still try some more tweaks. results are not terrible but might be some more room for improvement.

Make sure USB selective suspend is disabled
Make sure in USB hubs in device manager you disable allow computer to turn off this device
Uninstall everything Nvidia, run the installer again and select custom install and untick everything except for the graphics driver
You have things running in background (Acronis for example) - Usually not a great idea for DAW work and most stuff can just be run manually when you need it. Check Task manager/Start-Up and switch anything non essential to disabled.

How deos the USB affect the CPU after you’ve started Cubase ?

I’ve just been away from my pc and Cubase glitched when i started it up
I’ve just been to the power management and put hard discs to never as well as the USB selective suspend is disabled
So i’ll see how it works tomorrow

Because the CPU receives calls for its attention from all devices (USB, network card, anything). These interrupts take away capacity to compute from the CPU and introduce latency. We can perceive that in some cases as audio dropouts, stutter etc.

Some drivers are better than others. Update any/all drivers for your motherboard. Also, take a look at the replies in this thread to my original post. I’ve found them very useful.

Thanks I’ll disable the usb roots in device manager as well

OK, but do that one at a time to see which USB devices are affected. I disabled my USB mouse and keyboard! :blush:

All you want to do is untick “allow computer to turn off this device” for any USB Hubs in device manager".
You cannot disable your mouse and keyboard or any device by doing this. Not sure what you were doing :confused:

First post. I’m normally silent and lurk and find my solutions by trawling sometimes endless forum posts etc.

I had to come out of my lurkness state to echo this post. It’s the best thing I ever did in regards to showing significant improvement in audio stability and latency reduction and being able to maintain lower buffer sizes for so much longer. My situation was one of pure frustration having just purchased a UAD Apollo Twin USB3 interface and having expectations that were very high. I felt like a chump having just purchased this interface and Cubase Pro 9 and having audio performance worse then before. Some important considerations making the move to PCIe, the drivers. My success came from Renasas drivers having read that other Apollo usb3 users found them to be the solution they were looking for. You may have to buy 2 or 3 PCIe cards with different chipsets in order to find the right one unless your interface and associated forums/support have addressed these concerns by way of highlighting chipsets that they support. In the end, I purchased a generic PCIe card with a highly marketable name: I/O products. It didn’t matter the name or the country of origin, it was the chipset.

Hi
I’m sorted now after i disabled the USB in power management and i also turned hard disc turn off to never.
It maybe the glitching was the hard disc turning back on.
Also i have an old PCIe M-Audio card and the latency is 6 ms.
I’ve added that comment because a lot of people seem to have problems with USB interfaces