Option to turn off all spacing for final edits

I know this has come up before, but just putting out another request to please, please add an option to completely freeze the score and turn off any sort of automatic respacing.

I’m engraving a series of choral pieces for a publisher, and the composer is submitting revisions. Everything has been pretty straightforward, and the publisher is going to start “officially” soliciting Dorico submissions (yay!). But nearly every time I make an edit to the score, my staff spacing changes. Sometimes it changes in spots that don’t even seem related to the current edit. This has gotten me more than once, and it requires me to basically re-check the entire layout each time I make a small edit.

Here are several culprits:

  • bar numbers that I manually positioned get moved
  • manual staff spacing changes
  • adding dynamics re-spaces everything vertically

I would love to have the ability to effectively freeze the score—lock every single item on the page—so I can edit without fear of undoing. Thanks.

I would need to see specific examples in order to be able to say why you are seeing unexpected things change. In general you should find everything is stable, so the issues you’re experiencing sound, on the face of it, like bugs. So please provide projects and steps to reproduce the problems, and we’ll then be able to look into and, hopefully, fix them.

I’ll email you a file. There may be a bug or two involved regarding bar numbers, but I’m pretty sure some of this isn’t buggy at all. Some of what I’m asking for is simply different functionality.

A composer or editor may wish to add a hairpin above a vocal line on a page that is already pretty tightly spaced. In this case, it would be invaluable to be able to place the hairpin—collisions be darned—and resolve the collisions manually. At present, Dorico adjusts to avoid collisions. For much of my work, I LOVE this functionality… but for editing choral octavos, I don’t.

I don’t know if this sort of “dead score” option is on the team’s radar, but it would be huge for me.

You should find that switching off the ‘Automatically resolve collisions between adjacent staves and systems’ option on the Vertical Spacing page of Layout Options allows you to add things without the vertical spacing changing. The downside of that option, of course, is that if any staves or systems need to be moved from their default positions in order to resolve collisions, you have to do it yourself. In the future we may well add a means of writing the current calculated stave/system positions as explicit offsets, which would in theory allow you to switch off the ‘Automatically resolve collisions…’ option towards the end of the editing process and keep what had previously been calculated automatically up to that point.

Thanks Daniel, I hadn’t thought of that option. I’ll check it out.

Daniel, fwiw, I think that sounds nice. I see value to both positions: on the one hand, let Dorico do the hard work and get me 90+% of the way there. On the other hand, sometimes I want to tweak something tiny and things shift. That is very frustrating. (We’ve discussed this a lot in regards to horizontal lyric spacing vs. manual note spacing too.)

Another source of frustration for me personally is when I set explicit stave spacing and then copy that spacing to other pages. Then, for whatever reason, I decide that a measure needs to be bumped down to the next stave… and I lose all my staff spacing. I would have presumed that the ––horizontal–– spacing would necessarily shift (I am moving measures after all) but I would NOT expect the vertical real-estate to need to shift (especially if the notation is simple, straightforward and has nothing sticking out very far above or below the stave --necessitating-- collision avoidance). I can only presume this happens because that vertical offset (that was set manually) from the preceding stave was tied to the measure that is now in position #2 rather than #1 in that subsequent stave. If that property could be auto-transferred I’d definitely appreciate it.

If the rhythmic position of the start of a system changes, the staff spacing adjustment is removed. 'Twas ever thus, and will probably ever be so.

For me, “Locking” is a poor implementation. It’s essentially an admission that there’s not enough control over the layout to start with. (Look at Finale, where you have to nail everything down to make sure that things don’t randomly move about, and they still do anyway.)

In Dan’s ‘dynamic’ example, it might be better to include an “Avoid Collisions” Property, as with text; or set sufficiently ‘tight’ spacing parameters to minimize or negate any disruption from the outset. There may even be other possible solutions that Daniel and the team have thought about for longer than I have! :astonished:

I too would like to see a “locking” feature in Dorico. I’d like to be able to open a Dorico 2 file in Dorico 7 and be assured that all that is needed is a quick visual proof. May be hard to do and against the developer’s vision for the software, but just saying.

Never had that experience with Finale - I use it full time. Here is not the place to discuss Finale workflows but if you’d like to contact me privately I can tell you what works for me.

I agree… in this regard, I find Finale is generally quite predictably static (that is, when I turn off Automatic Note Spacing).

I probably don’t need to qualify how I feel about Finale generally… :wink:

My use case is with scores where every page needs to have the staves in exactly the same position. I set these to give space for the worst case page, but then minor edits come in and the page with edits shifts the vertical spacing. This isn’t to fit anything extra.

If you need to have the staves in exactly the same position on every page, you really should turn off the ‘Automatically resolve collisions between adjacent staves and systems’ option, as described above.

Maybe I’m missing something but I have been frustrated by layouts that were completed, locked and saved only to find when they are reopened that system and page breaks have changed. This seems to occur if I have pushed an extra bar into a line to help with page turns and manually set all subsequent system breaks on that page. I have spent nearly an hour trying to lock down a violin part so that the few available spots for page turns remain where I want them. I have tried locking frames from last to first, locking systems that were manually changed, checking that there is a system break flag on each line and frame break at the start of each frame. The part now appears to be stable but surely there is an easier way.

My question is what exactly does locking a frame or system do? What do I have to turn off to prevent Dorico from deciding that a line or a frame is too full and automatically re-spacing everything, pushing the last system of the page on to another page containing only one system?

Any help would be greatly appreciated.
Thanks,

Locking a frame adds a Frame Break at the start and another Frame Break at the end, and sets the first Frame Break to Wait for Next Frame Break. Locking a system adds a System Break at the start and another System Break at the end, and sets the first System Break to Wait for Next System Break.

In my experience, the problem with this is that when locking systems/frames, the “wait for next” properties of existing Frame/System Breaks are overwritten.
Basically, if you use the lock function multiple times on overlapping material, you can only trust the last lock you implemented.

Either use manual system breaks/frame breaks (for page turns I’d be going just with Frame Breaks, all set to Wait for Next Frame Break, OR lock. Don’t waste time trying to do both.

edit: and whatever you do, do this work with System Break and Frame Break signposts turned on. There’s no magic, and it’s quite easy to understand what’s happening if you can see it.

Dorico will never spontaneously decide to push a system out of one frame and into the next; if anything users probably wish that it would do this more often than it does, but it generally tries to maintain a stable approach to system formatting. The crucial thing, as Leo points out, is that if you want to prevent Dorico from making any changes to the formatting after inserting system and frame breaks is to ensure that ‘Wait for next… break’ is enabled.

Thanks Leo and Daniel:

I reopened the project today and the violin part was all scrambled again with two pages breaking systems in two and two frames pushing an extra line out of the frame onto a page with only one line.

Locking a frame adds a Frame Break at the start and another Frame Break at the end, and sets the first Frame Break to Wait for Next Frame Break. Locking a system adds a System Break at the start and another System Break at the end, and sets the first System Break to Wait for Next System Break.

In my experience, the problem with this is that when locking systems/frames, the “wait for next” properties of existing Frame/System Breaks are overwritten.

I checked all the signposts and, sure enough, the “wait for next” properties had been turned off in the offending pages.

So, if I understand correctly, to lock down a part or score so that nothing changes I must make sure that every line and every frame have the “wait until next” property set. Locking a frame or system is not enough.

Is there a way to do this globally?

Thanks,

Globally, no, but you can speed up the process. If you already have Frame Breaks on each page, you can

  1. Select one Frame Break
  2. Go Edit > Select More (Ctrl/Cmd+Shift+A)
  3. In Write mode, Filter just Frame Breaks.
  4. In Engrave mode, flick the “Wait for next Frame Break” switch.
    That will set them all at once (for that layout).

Thanks Leo. That finally works.

I am constantly having to adjust parts for page turns and this often involves pushing more bars into a system or more systems into a page than what Dorico creates with its excellent default spacing. I can’t help but think that it would be nice if the convoluted process you explained could be simplified and made more intuitive with a global lock command once I have made all my adjustments.

Maybe I’m wishing for more than is possible. Thanks again.

One other caveat: if I follow Leo’s sequence and the first frame break has both “wait for next frame break” and “wait for next system break” turned on, the properties panel will suggest that all frame breaks have both turned on even though some later ones don’t.

To be absolutely certain once all frame breaks are selected, I must turn off both flags and turn them on again to change any of the following frame breaks.

I am working with Dorico Pro 3.0.10.1051 in Windows 10.

Has anyone else seen this?