Ossia in final bar

Hi, I want to have an ossia in the last bar of a piece and I want the Ossia to show the final barline as well. When I extend the ossia to show the final barline, Dorico will create a new bar at the end. Any ideas how to show the final barline without getting a new bar?

It should be as simple as deleting the second ossia signpost.

Ah, that was very simple. I hope the additional question will be simple as well:
I couldn’t find a way to show the clef and key signature at the beginning of the ossia. Is there a setting for this or do one has to add these manually?

Select the ossia signpost and switch on the ‘Show preamble’ checkbox in the Properties panel.

Damn, that is of course the place to look for it. Sorry! Again, very simple!
I was looking through the Layout, Notations and Engraving Options for this.
Now I get a lot of space before and after the barline. It seems like Dorico is adding space for a normal size staff. Because there is nothing before the initial clef of the Ossia, Dorico doesn’t need to add space before the barline at all for my taste.
I just want to mention this. At least I know where to change the note spacing. :slight_smile:

After a second look, I found out, that Dorico is not adding space before the barline. Only after the barline for the key signature.