OSX High Sierra compatibility?

Minimum specs say Mohave onwards, unfortunately the studio MacPro can’t go beyond 10.13… Does SL7 work with High Sierra?

https://www.steinberg.net/forums/viewtopic.php?f=305&t=195332

Update on this : you can now run SL7 fully even if your CPU doesn’t support AVX instructions.
However if you run it on High Sierra, you may experience flickers when displaying VST3 plugins.