Out now: The Songwriter's VST Sound Instrument Set

With The Songwriter’s, we’re adding a new acoustic drum kit to the exquisite sound libraries of Groove Agent 4 and Groove Agent SE 4, spanning over 4 GB of drum sounds at a 24-bit resolution.

Key features:

• Acoustic drum kit played with sticks and hot rods
• 24-bit recordings with up to 16 velocities and 6 round robins
• 20 Styles for folk, country, soft rock and indie pop
• Each Style includes main parts, intros, endings and fills
• An inexhaustible resource for creating backing tracks, inspiring new compositions and improvisation sessions

Read more

Buy now

I have purchased and installed the Songwriter’s set but the patches will not load even though the new set appears in the media bay. It looks like it is not seeing the samples???


Can you please provide some information? Are you using Groove Agent 4 or the SE version? Are you on windows or Mac OS X? Which Cubase version?

Hi Matthias,

I am on Groove Agent 4. Running Cubase 7.5 (64 bit) on Windows 7.

Thanks in anticipation,


I had the same issue originally. By restarting Goove Agent a few times, it eventually located the samples. Not sure what I did to make it work – but at first, I also had trouble with it locating samples. Running OS X 10.9.5 and the latest update of Groove Agent 4.

Hi Ed,

Thanks for helping out. When you say restarting Groove Agent, do you mean reloading it into the instrument rack?



Alas…reloading didn’t work for me.

Still need help on this one guys :unamused:


Okay problem solved. There was an update to GA4 that didn’t appear on my start up panel in Cubase. I have downloaded it…installed it…and now the expansion pack works…Hussaaarrrrr!!!

I fixed this isue very easily by updating Cubase pro 8. Just download the latest version and Cubase will install the updates for Groove agent SE4.

I may be installing the package into the wrong folder. Where should it go in order to work best with Cubase 8. Have Groove Agent SE4 that came with Cubase 8. Have 8.2. I can’t load the agent. PermanentlyOff.vstpreset is the only preset listing usually but sometimes the other vstpresets for this new pack shows in the list but when double clicked only permanentlyoff.vstpreset loads in the programs slot but not the track preset slot in the inspector. Very confusing to me. I have installed it twice, once with other vst instruments in the usual folder I use and once inside the GrooveAgentSE folder in the Steinberg folder. Neither works. Restarting Groove Agent multiple times does not change anything. Restarting Cubase also does not help so far. Adding the folders to the vst 2 path doesn’t help. I’ll try again tomorrow but what do you think I am doing wrong on the information I’ve posted here? Anything obvious? Thanks. If I should start over to do it correctly is the place it installs the main thing that needs correcting or care taken?

When will the Styles be editable? Or do I live so I can keep paying your …t?

Thanks DFP91. Apparently, I had installed Cubase 8.0.20 for 32 bit (x86) on my 64 bit computer but somehow had not installed the 64 bit version. So I downloaded the 8.0.20 update (again) and it automatically chose the 64 bit version updates and ignored the 32 bit version updates saying I already had them. That did it.

I had the same problem. Thanks to this post, I 've found that I had to update groove agent 4. After the update, it gives me all the missing songwriter sounds. :smiley:
I made the upgrade from cubase artist 7.5 to 8 today and there were no mention about the need to upgrade grooveagent4 at all. I find this not normal, you should warn your customers about the need to upgrade before buying songwriter instrument set. :bulb:

I had a similar problem with the Simon Phillips expansion. I just installed GA 4 for the first time, then the Phillips expansion, and I couldn’t get the Phillips sets to load. Then I saw there was an update to GA4, installed it, and the Phillips expansions loaded fine. I had tried several reboots and reinstalls with no luck before installing the GA4 update.